summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/plotutils/plotutils-2.6-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/plotutils/plotutils-2.6-r1.ebuild')
-rw-r--r--media-libs/plotutils/plotutils-2.6-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/plotutils/plotutils-2.6-r1.ebuild b/media-libs/plotutils/plotutils-2.6-r1.ebuild
new file mode 100644
index 000000000000..ca73edbfb119
--- /dev/null
+++ b/media-libs/plotutils/plotutils-2.6-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit libtool eutils autotools
+
+DESCRIPTION="Powerful C/C++ function library for exporting 2-D vector graphics"
+HOMEPAGE="http://www.gnu.org/software/plotutils/"
+SRC_URI="mirror://gnu/plotutils/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+png static-libs X"
+
+DEPEND="
+ !<media-libs/plotutils-${PV}
+ media-libs/libxmi
+ png? (
+ media-libs/libpng
+ sys-libs/zlib )
+ X? (
+ x11-libs/libXaw
+ x11-proto/xextproto )"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS COMPAT ChangeLog INSTALL.* KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO"
+
+src_prepare() {
+ rm -rf libxmi/* || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ epatch \
+ "${FILESDIR}"/${PN}-2.5.1-rangecheck.patch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-libpng-1.5.patch \
+ "${FILESDIR}"/${P}-libxmi.patch
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ if use X ; then
+ myconf="--with-x --enable-libxmi"
+ else
+ myconf="--without-x"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ --enable-libplotter \
+ --disable-libxmi \
+ $(use_enable static-libs static) \
+ $(use_with png libpng) \
+ ${myconf}
+}
+
+pkg_postinst() {
+ if use X ; then
+ elog "There are extra fonts available in the plotutils package."
+ elog "The current ebuild does not install them for you since most"
+ elog "of them can be installed via the media-fonts/urw-fonts"
+ elog "package. See /usr/share/doc/${P}/INSTALL.fonts for"
+ elog "information on installing the remaining Tektronix fonts."
+ elog ""
+ elog "If you manually install the extra fonts and use the"
+ elog "program xfig, you might want to recompile to take"
+ elog "advantage of the additional ps fonts."
+ elog "Also, it is possible to enable ghostscript and possibly"
+ elog "your printer to use the HP fonts."
+ fi
+}