summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmpd')
-rw-r--r--media-libs/libmpd/Manifest1
-rw-r--r--media-libs/libmpd/files/libmpd-11.8.17-remove-strndup.patch15
-rw-r--r--media-libs/libmpd/libmpd-11.8.17-r1.ebuild43
-rw-r--r--media-libs/libmpd/libmpd-11.8.17.ebuild37
-rw-r--r--media-libs/libmpd/metadata.xml10
5 files changed, 106 insertions, 0 deletions
diff --git a/media-libs/libmpd/Manifest b/media-libs/libmpd/Manifest
new file mode 100644
index 000000000000..e9cf0fab9216
--- /dev/null
+++ b/media-libs/libmpd/Manifest
@@ -0,0 +1 @@
+DIST libmpd-11.8.17.tar.gz 365015 SHA256 fe20326b0d10641f71c4673fae637bf9222a96e1712f71f170fca2fc34bf7a83 SHA512 ffe2880834a4a39745a5327d628781e16eeb8cd1ec17402dda46ad96ff402bc0d8b4312ba058a39242ad9bb8c3a0bb6feb2c5ea2a30ef9be97652fdb5c02572d WHIRLPOOL b5fe844e7a21229c2c4a50080964e13ee1bc7b69257b604d0a62e476ae24df24b6923bd8cdd9970d2335aa27a84c68f8c33983527304f16e32ccc35d5bcacca2
diff --git a/media-libs/libmpd/files/libmpd-11.8.17-remove-strndup.patch b/media-libs/libmpd/files/libmpd-11.8.17-remove-strndup.patch
new file mode 100644
index 000000000000..ad4fdc02ef3e
--- /dev/null
+++ b/media-libs/libmpd/files/libmpd-11.8.17-remove-strndup.patch
@@ -0,0 +1,15 @@
+diff --git a/src/libmpd-internal.h b/src/libmpd-internal.h
+index c84c3a4..51be441 100644
+--- a/src/libmpd-internal.h
++++ b/src/libmpd-internal.h
+@@ -206,10 +206,6 @@ int mpd_unlock_conn(MpdObj *mi);
+ MpdData * mpd_misc_sort_tag_list(MpdData *data);
+
+
+-#ifndef HAVE_STRNDUP
+-char * strndup (const char *s, size_t n);
+-#endif
+-
+ int mpd_server_get_allowed_commands(MpdObj *mi);
+ typedef enum _MpdSearchType {
+ MPD_SEARCH_TYPE_NONE,
diff --git a/media-libs/libmpd/libmpd-11.8.17-r1.ebuild b/media-libs/libmpd/libmpd-11.8.17-r1.ebuild
new file mode 100644
index 000000000000..bcaa3a52fd2a
--- /dev/null
+++ b/media-libs/libmpd/libmpd-11.8.17-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A library handling connections to a MPD server"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Libmpd"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2.16:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-remove-strndup.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_compile() {
+ emake
+ use doc && emake -C doc doc
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die
+ rm "${ED}"/usr/share/doc/${PF}/{README,ChangeLog} || die
+}
diff --git a/media-libs/libmpd/libmpd-11.8.17.ebuild b/media-libs/libmpd/libmpd-11.8.17.ebuild
new file mode 100644
index 000000000000..8dba3c0f5eaa
--- /dev/null
+++ b/media-libs/libmpd/libmpd-11.8.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A library handling connections to a MPD server"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Libmpd"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2.16:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_compile() {
+ emake
+ use doc && emake -C doc doc
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die
+ rm "${ED}"/usr/share/doc/${PF}/{README,ChangeLog} || die
+}
diff --git a/media-libs/libmpd/metadata.xml b/media-libs/libmpd/metadata.xml
new file mode 100644
index 000000000000..e9f44e438159
--- /dev/null
+++ b/media-libs/libmpd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+</maintainer>
+<longdescription>A library handling connection to a MPD server.</longdescription>
+</pkgmetadata>