summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/faad2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/faad2')
-rw-r--r--media-libs/faad2/Manifest1
-rw-r--r--media-libs/faad2/faad2-2.7-r3.ebuild50
-rw-r--r--media-libs/faad2/files/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch13
-rw-r--r--media-libs/faad2/files/faad2-2.7-libmp4ff-shared-lib.patch29
-rw-r--r--media-libs/faad2/files/faad2-2.7-man1_MANS.patch10
-rw-r--r--media-libs/faad2/metadata.xml12
6 files changed, 115 insertions, 0 deletions
diff --git a/media-libs/faad2/Manifest b/media-libs/faad2/Manifest
new file mode 100644
index 000000000000..5333a9280f84
--- /dev/null
+++ b/media-libs/faad2/Manifest
@@ -0,0 +1 @@
+DIST faad2-2.7.tar.gz 1137407 SHA256 ee26ed1e177c0cd8fa8458a481b14a0b24ca0b51468c8b4c8b676fd3ceccd330 SHA512 8135370497dfcfee09094a03a4a9545ebc58b9e532b89c5d6e5037042549e12ddb75f8903aa05866afac9fa28df96320f1ed2eebffc0660578e54392a51c1161 WHIRLPOOL 6e30d466e47de0e06751718005573a632c5aa0cd209445c56c25d859f917265452676ce897ac5ad1cd308d411911aaf232bfc50904469f9434b2cc95b6ae928f
diff --git a/media-libs/faad2/faad2-2.7-r3.ebuild b/media-libs/faad2/faad2-2.7-r3.ebuild
new file mode 100644
index 000000000000..04739320b964
--- /dev/null
+++ b/media-libs/faad2/faad2-2.7-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="AAC audio decoding library"
+HOMEPAGE="http://www.audiocoding.com/faad2.html"
+SRC_URI="mirror://sourceforge/faac/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="digitalradio static-libs"
+DOCS=( AUTHORS ChangeLog NEWS README README.linux TODO )
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r1
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libmp4ff-shared-lib.patch \
+ "${FILESDIR}"/${P}-libmp4ff-install-mp4ff_int_types_h.patch \
+ "${FILESDIR}"/${P}-man1_MANS.patch
+
+ sed -i -e 's:iquote :I:' libfaad/Makefile.am || die
+
+ # bug 466986
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --disable-dependency-tracking \
+ $(use_with digitalradio drm) \
+ --without-xmms
+
+ # do not build the frontend for non default abis
+ if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ sed -i -e 's/frontend//' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
diff --git a/media-libs/faad2/files/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch b/media-libs/faad2/files/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
new file mode 100644
index 000000000000..5d39cad95d7e
--- /dev/null
+++ b/media-libs/faad2/files/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
@@ -0,0 +1,13 @@
+Install mp4ff_int_types.h for mythmusic.
+
+http://bugs.gentoo.org/275008
+
+--- common/mp4ff/Makefile.am
++++ common/mp4ff/Makefile.am
+@@ -1,5 +1,5 @@
+ lib_LTLIBRARIES = libmp4ff.la
+-include_HEADERS = mp4ff.h mp4ffint.h
++include_HEADERS = mp4ff.h mp4ffint.h mp4ff_int_types.h
+
+ AM_CFLAGS = -DUSE_TAGGING=1
+
diff --git a/media-libs/faad2/files/faad2-2.7-libmp4ff-shared-lib.patch b/media-libs/faad2/files/faad2-2.7-libmp4ff-shared-lib.patch
new file mode 100644
index 000000000000..56a131192969
--- /dev/null
+++ b/media-libs/faad2/files/faad2-2.7-libmp4ff-shared-lib.patch
@@ -0,0 +1,29 @@
+Ripped from Debian
+
+Patch to create a shared lib for libmp4ff.
+
+--- a/common/mp4ff/Makefile.am
++++ b/common/mp4ff/Makefile.am
+@@ -1,7 +1,8 @@
+-lib_LIBRARIES = libmp4ff.a
++lib_LTLIBRARIES = libmp4ff.la
+ include_HEADERS = mp4ff.h mp4ffint.h
+
+-libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
++AM_CFLAGS = -DUSE_TAGGING=1
+
+-libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
++libmp4ff_la_LDFLAGS = -version-info 0:0:0
++libmp4ff_la_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
+ mp4tagupdate.c mp4ff.h mp4ffint.h mp4ff_int_types.h
+--- a/frontend/Makefile.am
++++ b/frontend/Makefile.am
+@@ -5,7 +5,7 @@
+ -I$(top_srcdir)/common/mp4ff
+
+ faad_LDADD = $(top_builddir)/libfaad/libfaad.la \
+- $(top_builddir)/common/mp4ff/libmp4ff.a
++ $(top_builddir)/common/mp4ff/libmp4ff.la
+
+ faad_SOURCES = main.c \
+ audio.c audio.h \
diff --git a/media-libs/faad2/files/faad2-2.7-man1_MANS.patch b/media-libs/faad2/files/faad2-2.7-man1_MANS.patch
new file mode 100644
index 000000000000..9c1ddb01bc31
--- /dev/null
+++ b/media-libs/faad2/files/faad2-2.7-man1_MANS.patch
@@ -0,0 +1,10 @@
+diff -ur faad2-2.7.orig/frontend/Makefile.am faad2-2.7/frontend/Makefile.am
+--- faad2-2.7.orig/frontend/Makefile.am 2009-02-06 18:03:37.000000000 +0200
++++ faad2-2.7/frontend/Makefile.am 2009-07-20 20:27:29.000000000 +0300
+@@ -1,5 +1,5 @@
+ bin_PROGRAMS = faad
+-man_MANS = faad.man
++man1_MANS = faad.man
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/faad \
+ -I$(top_srcdir)/common/mp4ff
diff --git a/media-libs/faad2/metadata.xml b/media-libs/faad2/metadata.xml
new file mode 100644
index 000000000000..3cd31fce10b9
--- /dev/null
+++ b/media-libs/faad2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>The fastest ISO AAC audio decoder available, correctly decodes all MPEG-4 and MPEG-2 MAIN, LOW, LTP, LD and ER object type AAC files</longdescription>
+ <use>
+ <flag name="digitalradio">Digital Radio Mondiale (warning: disables other decoders)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">faac</remote-id>
+ </upstream>
+</pkgmetadata>