summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-28 08:22:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-28 10:44:03 -0400
commit05387845c828dcacbc036e9af58b609003ca0bf1 (patch)
treef9c393b6678efde97b422442892072c6563b8d37 /media-gfx
parentgames-strategy/naev: drop 0.11.3 (diff)
downloadgentoo-05387845c828dcacbc036e9af58b609003ca0bf1.tar.gz
gentoo-05387845c828dcacbc036e9af58b609003ca0bf1.tar.bz2
gentoo-05387845c828dcacbc036e9af58b609003ca0bf1.zip
media-gfx/ueberzugpp: drop 2.9.5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index 17dbd46ae11d..88fcaf5db155 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1,2 +1 @@
-DIST ueberzugpp-2.9.5.tar.gz 69268 BLAKE2B 9a31c7d5135ca0c5b85e250f9cbb5fb10e22344a7c6bf5393a04ec928580844470b24b0471aa609a83a0f1cbfed17944aabdec9ee5d6ddffe90720fa46bf80ad SHA512 43576ba504ec66a909c170122db808a8ae55535d54cad09172590af2790c981b1bfba6ba0f749a5ca9881a15cfdcdb0c34fbb2533f72011a786fd1413d1f91c4
DIST ueberzugpp-2.9.6.tar.gz 69379 BLAKE2B 86d29724ff768536bef2385d456d61509db58c8e83fe0c9711684f86b70e1e45d1d1bb7b970a036c408f575e8d31659b336111cfcc0dc39f7867010e56d9e79b SHA512 bb70933cbc887cc3967c6011f0616d056f5723f333f6cfd70e7a3dd785791b83b9855c0b3d0c901efc59d65ba113462946bc0f08d57cf845ec6c59ec861da874
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild
deleted file mode 100644
index 1cb4d698e37a..000000000000
--- a/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic toolchain-funcs
-
-DESCRIPTION="Drop in replacement for ueberzug written in C++"
-HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
-SRC_URI="
- https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="X dbus opencv opengl wayland xcb-errors"
-REQUIRED_USE="xcb-errors? ( X )"
-
-RDEPEND="
- dev-cpp/tbb:=
- dev-libs/glib:2
- dev-libs/libfmt:=
- dev-libs/openssl:=
- dev-libs/spdlog:=
- media-gfx/chafa
- media-libs/libsixel
- media-libs/vips:=
- X? (
- x11-libs/libxcb:=
- x11-libs/xcb-util-image
- xcb-errors? ( x11-libs/xcb-util-errors )
- )
- dbus? ( sys-apps/dbus )
- opencv? ( media-libs/opencv:= )
- opengl? ( media-libs/libglvnd )
- wayland? ( dev-libs/wayland )
- !media-gfx/ueberzug
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/cli11
- dev-cpp/nlohmann_json
- dev-cpp/range-v3
- X? ( x11-base/xorg-proto )
- wayland? ( dev-libs/wayland-protocols )
-"
-BDEPEND="
- wayland? (
- dev-util/wayland-scanner
- kde-frameworks/extra-cmake-modules
- )
-"
-
-src_configure() {
- if use X && tc-is-clang && has_version sys-libs/libcxx; then
- # X support makes use of C++20's std::jthread which is currently
- # marked experimental (at least) in <=libcxx-18 (should limit
- # version in above libcxx check whenever this becomes unnecessary)
- append-cxxflags $(test-flags-CXX -fexperimental-library)
- fi
-
- # TODO?: wayfire plugin is skipped for now (needs wlroots which is
- # likely to be messier), but could be handled if there is a demand
-
- local mycmakeargs=(
- -DENABLE_DBUS=$(usex dbus)
- -DENABLE_OPENCV=$(usex opencv)
- -DENABLE_OPENGL=$(usex opengl)
- -DENABLE_TURBOBASE64=no # not packaged
- -DENABLE_WAYLAND=$(usex wayland)
- -DENABLE_X11=$(usex X)
- -DENABLE_XCB_ERRORS=$(usex xcb-errors)
- -DFETCHCONTENT_FULLY_DISCONNECTED=yes
- )
-
- cmake_src_configure
-}