summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/kfax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/kfax')
-rw-r--r--media-gfx/kfax/Manifest1
-rw-r--r--media-gfx/kfax/files/kfax-3.3.6-kde45.patch12
-rw-r--r--media-gfx/kfax/files/kfax-3.3.6-underlinking.patch12
-rw-r--r--media-gfx/kfax/kfax-3.3.6-r1.ebuild38
-rw-r--r--media-gfx/kfax/metadata.xml5
5 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/kfax/Manifest b/media-gfx/kfax/Manifest
new file mode 100644
index 000000000000..cce433421c9d
--- /dev/null
+++ b/media-gfx/kfax/Manifest
@@ -0,0 +1 @@
+DIST kfax-3.3.6-kde4.4.0.tar.bz2 311468 SHA256 6897b25f72a49c9bc0f99bf03fced5023c6d76e8746b23fd7ddf73b8a16c6d1d
diff --git a/media-gfx/kfax/files/kfax-3.3.6-kde45.patch b/media-gfx/kfax/files/kfax-3.3.6-kde45.patch
new file mode 100644
index 000000000000..60bedf093eeb
--- /dev/null
+++ b/media-gfx/kfax/files/kfax-3.3.6-kde45.patch
@@ -0,0 +1,12 @@
+diff -ru kfax-3.3.6-kde4.4.0.orig/kfax.cpp kfax-3.3.6-kde4.4.0/kfax.cpp
+--- kfax-3.3.6-kde4.4.0.orig/kfax.cpp 2010-02-11 21:52:12.000000000 +0100
++++ kfax-3.3.6-kde4.4.0/kfax.cpp 2010-11-14 00:13:21.386377691 +0100
+@@ -829,7 +829,7 @@
+ statusbar->showMessage( i18n( "Saving..." ) );
+
+ KUrl source(thispage->pathname);
+- KIO::FileCopyJob *job = KIO::file_copy(source, dest,KIO::Overwrite | KIO::HideProgressInfo);
++ KIO::FileCopyJob *job = KIO::file_copy(source, dest, -1, KIO::Overwrite | KIO::HideProgressInfo);
+ bool ok = job->exec();
+ statusbar->clearMessage();
+
diff --git a/media-gfx/kfax/files/kfax-3.3.6-underlinking.patch b/media-gfx/kfax/files/kfax-3.3.6-underlinking.patch
new file mode 100644
index 000000000000..701308951b63
--- /dev/null
+++ b/media-gfx/kfax/files/kfax-3.3.6-underlinking.patch
@@ -0,0 +1,12 @@
+diff -ruN kfax-3.3.6-kde4.4.0.orig/CMakeLists.txt kfax-3.3.6-kde4.4.0/CMakeLists.txt
+--- kfax-3.3.6-kde4.4.0.orig/CMakeLists.txt 2010-02-11 21:59:47.000000000 +0100
++++ kfax-3.3.6-kde4.4.0/CMakeLists.txt 2011-08-11 21:33:15.262295828 +0200
+@@ -12,7 +12,7 @@
+
+ kde4_add_executable(kfax ${kfax_SRCS})
+
+-target_link_libraries(kfax ${KDE4_KIO_LIBS} ${QT_QT3SUPPORT_LIBRARY} )
++target_link_libraries(kfax ${KDE4_KIO_LIBS} ${QT_QT3SUPPORT_LIBRARY} ${X11_LIBRARIES})
+
+ install(TARGETS kfax ${INSTALL_TARGETS_DEFAULT_ARGS} )
+
diff --git a/media-gfx/kfax/kfax-3.3.6-r1.ebuild b/media-gfx/kfax/kfax-3.3.6-r1.ebuild
new file mode 100644
index 000000000000..1141b2629697
--- /dev/null
+++ b/media-gfx/kfax/kfax-3.3.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="af ar be bg br ca ca@valencia cs cy da de el en_GB eo es et eu fa
+fi fr ga gl he hi hne hr hu is it ja km ko lt lv mai mk ms nb nds ne nl nn oc
+pa pl pt pt_BR ro ru se sk sl sv ta tg th tr uk vi wa xh zh_CN zh_HK zh_TW"
+KDE_DOC_DIRS="doc-translations/%lingua_${PN}"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+KDE_VERSION=4.4.0
+MY_P=${P}-kde${KDE_VERSION}
+
+DESCRIPTION="A fax file viewer"
+HOMEPAGE="http://www.kde.org/"
+SRC_URI="mirror://kde/stable/${KDE_VERSION}/src/extragear/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-kde45.patch"
+ "${FILESDIR}/${P}-underlinking.patch"
+)
diff --git a/media-gfx/kfax/metadata.xml b/media-gfx/kfax/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/media-gfx/kfax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>