summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 16:07:22 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 16:07:22 +0100
commiteed3f1879631c9b54480cb9383ae990472c0a47b (patch)
treeebc5d26ba293ea8b4e0276fd68b055933b2d3f00 /media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
parentmedia-gfx/pngtools: Port to EAPI 7 (diff)
downloadgentoo-eed3f1879631c9b54480cb9383ae990472c0a47b.tar.gz
gentoo-eed3f1879631c9b54480cb9383ae990472c0a47b.tar.bz2
gentoo-eed3f1879631c9b54480cb9383ae990472c0a47b.zip
media-gfx/hp2xx: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch')
-rw-r--r--media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch25
1 files changed, 19 insertions, 6 deletions
diff --git a/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch b/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
index 9bff4f43b922..d9f3edb84947 100644
--- a/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
+++ b/media-gfx/hp2xx/files/hp2xx-3.4.4-r1.patch
@@ -1,6 +1,20 @@
-diff -ruN hp2xx-3.4.4.orig/makes/generic.mak hp2xx-3.4.4/makes/generic.mak
---- hp2xx-3.4.4.orig/makes/generic.mak 2003-06-21 17:16:35.000000000 +0200
-+++ hp2xx-3.4.4/makes/generic.mak 2012-02-07 22:30:29.000000000 +0100
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,9 @@
+
+ all:
+- cd sources; make
++ cd sources && $(MAKE)
+
+ clean:
+- cd sources; make clean
++ cd sources && $(MAKE) clean
+
+ install:
+- cd sources; make install
++ cd sources && $(MAKE) install
+--- a/makes/generic.mak
++++ b/makes/generic.mak
@@ -30,11 +30,11 @@
CP = cp
MKINFO = makeinfo
@@ -115,9 +129,8 @@ diff -ruN hp2xx-3.4.4.orig/makes/generic.mak hp2xx-3.4.4/makes/generic.mak
$(BINDCMD)
-diff -ruN hp2xx-3.4.4.orig/sources/png.c hp2xx-3.4.4/sources/png.c
---- hp2xx-3.4.4.orig/sources/png.c 2003-06-21 17:31:51.000000000 +0200
-+++ hp2xx-3.4.4/sources/png.c 2012-02-07 22:26:33.000000000 +0100
+--- a/sources/png.c
++++ b/sources/png.c
@@ -5,6 +5,7 @@
#include <stdio.h>
#include <stdlib.h>