summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-extra/mate-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-extra/mate-utils')
-rw-r--r--mate-extra/mate-utils/Manifest2
-rw-r--r--mate-extra/mate-utils/mate-utils-1.8.0.ebuild86
-rw-r--r--mate-extra/mate-utils/mate-utils-1.8.1.ebuild86
-rw-r--r--mate-extra/mate-utils/metadata.xml11
4 files changed, 185 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
new file mode 100644
index 000000000000..2e3f0c00991e
--- /dev/null
+++ b/mate-extra/mate-utils/Manifest
@@ -0,0 +1,2 @@
+DIST mate-utils-1.8.0.tar.xz 2681836 SHA256 490d187d67c4f542cf3b8e63337acc1a9b7090c519adb844600b9d00da0b5cf0 SHA512 766fce72f7b486c3aa67e9a40b10207fbca36e7933cb7238bf0d6ac5a5e5165d5900ceb697c9af96f1135110b9b3985e349e9bc071a5174fe3fe0776ba0c4cd5 WHIRLPOOL 77fff5f47c83fa6884403f30194b606346659651f077912364907d8e3b6ad95e9eae974012aa8c54db31381231190077d362e402afe4f87279695871ab78144b
+DIST mate-utils-1.8.1.tar.xz 2648184 SHA256 0ad9c40c656214caaa6cbd2107ebb13e3cea0b64b4e31c7105568726313522a5 SHA512 71a6a57365a067012447222b2ef4b768234b2e58bf88b5b45c6e4b7f746c81136ea1dfee45257406b19f2c4f4c51adc3279b09f7c9c41bfe7be9c66321ad0eef WHIRLPOOL fc35c564fb378ebfc147b9344790aae5a3934e86f6cf642dedb2ab98ae093bb259e298f4fa6de98157f3c4775445862888a56464de8852d829e6040f9a42fc95
diff --git a/mate-extra/mate-utils/mate-utils-1.8.0.ebuild b/mate-extra/mate-utils/mate-utils-1.8.0.ebuild
new file mode 100644
index 000000000000..3a1ddf82a744
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.8.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Utilities for the MATE desktop"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="X applet ipv6 test"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.20:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4:0[gtk]
+ sys-libs/zlib:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ x11-libs/libXext:0
+ x11-libs/pango:0
+ applet? ( >=mate-base/mate-panel-1.8:0 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.8:0
+ x11-proto/xextproto:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove -D.*DISABLE_DEPRECATED cflagss
+ # This method is kinda prone to breakage. Recheck carefully with next bump.
+ # bug 339074
+ LC_ALL=C find . -iname 'Makefile.am' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
+ LC_ALL=C find . -iname 'Makefile.in' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ if ! use test; then
+ sed -e 's/ tests//' -i logview/Makefile.{am,in} || die
+ fi
+
+ # Fix up desktop files.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e 's/Categories\(.*\)MATE/Categories\1X-MATE/' -i {} + || die
+}
+
+src_configure() {
+ local myconf
+ if ! use debug; then
+ myconf="${myconf} --enable-debug=minimum"
+ fi
+
+ gnome2_src_configure \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_with X x) \
+ --disable-maintainer-flags \
+ --enable-zlib \
+ ${myconf}
+}
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
diff --git a/mate-extra/mate-utils/mate-utils-1.8.1.ebuild b/mate-extra/mate-utils/mate-utils-1.8.1.ebuild
new file mode 100644
index 000000000000..f0ddb2213045
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.8.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Utilities for the MATE desktop"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X applet ipv6 test"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.20:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4:0[gtk]
+ sys-libs/zlib:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ x11-libs/libXext:0
+ x11-libs/pango:0
+ applet? ( >=mate-base/mate-panel-1.8:0 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.8:0
+ x11-proto/xextproto:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove -D.*DISABLE_DEPRECATED cflagss
+ # This method is kinda prone to breakage. Recheck carefully with next bump.
+ # bug 339074
+ LC_ALL=C find . -iname 'Makefile.am' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
+ LC_ALL=C find . -iname 'Makefile.in' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ if ! use test; then
+ sed -e 's/ tests//' -i logview/Makefile.{am,in} || die
+ fi
+
+ # Fix up desktop files.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e 's/Categories\(.*\)MATE/Categories\1X-MATE/' -i {} + || die
+}
+
+src_configure() {
+ local myconf
+ if ! use debug; then
+ myconf="${myconf} --enable-debug=minimum"
+ fi
+
+ gnome2_src_configure \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_with X x) \
+ --disable-maintainer-flags \
+ --enable-zlib \
+ ${myconf}
+}
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
diff --git a/mate-extra/mate-utils/metadata.xml b/mate-extra/mate-utils/metadata.xml
new file mode 100644
index 000000000000..dca77826b865
--- /dev/null
+++ b/mate-extra/mate-utils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <use>
+ <flag name="applet">Enable the mate dictionary applet</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-utils</remote-id>
+ </upstream>
+</pkgmetadata>