summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 23:42:07 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 23:42:39 +0300
commit6cfbb6aee09ef269a46d3d2c3df8556bbe632b2f (patch)
tree9cca269f97513b20496fe04e7621bd403df0f849 /mate-extra/mate-polkit
parentpackage.mask: Last rite dev-vcs/git-bzr-ng as well (diff)
downloadgentoo-6cfbb6aee09ef269a46d3d2c3df8556bbe632b2f.tar.gz
gentoo-6cfbb6aee09ef269a46d3d2c3df8556bbe632b2f.tar.bz2
gentoo-6cfbb6aee09ef269a46d3d2c3df8556bbe632b2f.zip
mate-extra/mate-polkit: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mate-extra/mate-polkit')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.22.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 2b1e7f359030..2db8f6b98242 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1 +1,2 @@
DIST mate-polkit-1.18.2.tar.xz 348272 BLAKE2B 38b2359be2f908181805fa213fcd6973d8b208bc52542702b19a7dc8162ea316540ad8c524b102b6fd95d85dd1e87c3eda29023c798dedf39eb301ff7f691d14 SHA512 4150e0a18ecc1ea1d554334ca3725ab62008f9ea5693ab95eb70df408cfd08a46717d3252017f14f99e9389a2e106add1f74fd63d26cd5db9011707a5a4f63f9
+DIST mate-polkit-1.22.0.tar.xz 302080 BLAKE2B 374fa5215c57a36fc3a6fa4660866b33bc02d067f1eaf5cbadca8711efe8771e4c59d496e8eb47c75567b5a0e472fd10782c5b5436b9d2a5e7fc834445e5cf06 SHA512 e761ec10842789b5bbb3831f568c64e969429131a893850e8323927b949e115a24b3907fd3def7f31f5f785f0831717d852c61f08a9028a009ea9cca0ba86393
diff --git a/mate-extra/mate-polkit/mate-polkit-1.22.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.22.0.ebuild
new file mode 100644
index 000000000000..b90bf8fd614b
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.22.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+ >=sys-auth/polkit-0.102
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.14.0:3
+ appindicator? ( dev-libs/libappindicator:3 )"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}