summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-11-07 16:56:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-07 17:03:37 +0200
commitb6bfcfc2d41635e7ba926631619cf9b7d8eef02b (patch)
tree4e9433970bb36513cf350406d23016f6c0413f33 /mail-client
parentwww-client/firefox: fix ebuilds to reflect latest llvm.eclass changes (diff)
downloadgentoo-b6bfcfc2d41635e7ba926631619cf9b7d8eef02b.tar.gz
gentoo-b6bfcfc2d41635e7ba926631619cf9b7d8eef02b.tar.bz2
gentoo-b6bfcfc2d41635e7ba926631619cf9b7d8eef02b.zip
mail-client/thunderbird: fix ebuilds to reflect latest llvm.eclass changes
- also match lld to a slot. Bug: https://bugs.gentoo.org/879177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-102.4.0.ebuild10
-rw-r--r--mail-client/thunderbird/thunderbird-102.4.2.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/mail-client/thunderbird/thunderbird-102.4.0.ebuild b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
index 1ff0425c8ce4..50477ea0ed9b 100644
--- a/mail-client/thunderbird/thunderbird-102.4.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
@@ -200,8 +200,8 @@ llvm_check_deps() {
fi
if use clang ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
@@ -567,10 +567,12 @@ src_configure() {
einfo "Current RUSTFLAGS:\t\t${RUSTFLAGS:-no value set}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
AS=llvm-as
CC=${CHOST}-clang
diff --git a/mail-client/thunderbird/thunderbird-102.4.2.ebuild b/mail-client/thunderbird/thunderbird-102.4.2.ebuild
index b08367f7693f..0eb9f754ddff 100644
--- a/mail-client/thunderbird/thunderbird-102.4.2.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.4.2.ebuild
@@ -200,8 +200,8 @@ llvm_check_deps() {
fi
if use clang ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
@@ -567,10 +567,12 @@ src_configure() {
einfo "Current RUSTFLAGS:\t\t${RUSTFLAGS:-no value set}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
AS=llvm-as
CC=${CHOST}-clang