summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
commit4186eabcad11c1cf1a6fdc6a555b72404eee0137 (patch)
tree7a07ac977ec9f17772623b3ec02801d5dad964f9 /kde-apps/kopete
parentapp-crypt/certbot: fixing acme dep (diff)
downloadgentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.gz
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.bz2
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.zip
kde-apps: Add KDE Applications 18.04.3
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-18.04.3.ebuild179
2 files changed, 180 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index f46ca8c19510..f734c636bd82 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1 +1,2 @@
DIST kopete-18.04.2.tar.xz 9569128 BLAKE2B 87a8e398f9db0d11057beb281c2604b3b5b2169526fd9dbff6a6de15b79e4d895be57c9255dee90c8e97a8456ca9d99eb6b156ca492e49141d614742c204930d SHA512 b015fd30344f2d55c4026332d9c51578b0ac242d329503b9b8039c1c1b5d18dcafe7122a9d79820452978a55c3ca19fbfdefa68c444ded5ed81afaaca348f746
+DIST kopete-18.04.3.tar.xz 9568508 BLAKE2B c20ffb4ffdde34f94a400a7a42b6c36a3432df8db438b9c94cff50dec5b9a39f03679dbbc1a38151c517d99ee4d8bb4c8b7ad0e79e4947ad1643cc0f7d0064a7 SHA512 568f36895f66df00e4207e893b7a782111df5fee6a875d77aad30a214088589d1c317c0131eb3b21b264224fb8bde239b31af8c9cda4405079990e3f5999edc1
diff --git a/kde-apps/kopete/kopete-18.04.3.ebuild b/kde-apps/kopete/kopete-18.04.3.ebuild
new file mode 100644
index 000000000000..63ad39620103
--- /dev/null
+++ b/kde-apps/kopete/kopete-18.04.3.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# yahoo: media-libs/jasper (service shutdown)
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep libkleo)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ media-libs/phonon[qt5(+)]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt5(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0=
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp:=
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt5(+)]
+ net-dns/libidn:0=
+ sys-libs/zlib:=
+ )
+ zeroconf? (
+ $(add_frameworks_dep kdnssd)
+ $(add_kdeapps_dep kidentitymanagement)
+ )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMONDEPEND}
+ x11-base/xorg-proto
+ jingle? ( dev-libs/jsoncpp )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ $(cmake-utils_use_find_package jingle LiboRTP)
+ $(cmake-utils_use_find_package jingle Mediastreamer)
+ $(cmake-utils_use_find_package jingle Speex)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}