summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-07 17:34:05 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-08 02:43:30 -0500
commit5d6fa1ab93818b55f214309bf3444873fe8456db (patch)
tree7a39cfefcf70888f7cd6db7e7af935f3e5be92f4 /games-server/monopd/monopd-0.10.2.ebuild
parentgames-emulation/nestopia: clean old (drop ppc support) (diff)
downloadgentoo-5d6fa1ab93818b55f214309bf3444873fe8456db.tar.gz
gentoo-5d6fa1ab93818b55f214309bf3444873fe8456db.tar.bz2
gentoo-5d6fa1ab93818b55f214309bf3444873fe8456db.zip
games-server/monopd: version bump; drop ppc due to missing dep
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-server/monopd/monopd-0.10.2.ebuild')
-rw-r--r--games-server/monopd/monopd-0.10.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-server/monopd/monopd-0.10.2.ebuild b/games-server/monopd/monopd-0.10.2.ebuild
new file mode 100644
index 000000000000..6f09f3d2921a
--- /dev/null
+++ b/games-server/monopd/monopd-0.10.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils systemd games
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=dev-cpp/muParser-2
+ dev-libs/utfcpp"
+
+src_prepare() {
+ sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e "s:/usr/sbin:${GAMES_BINDIR}:" \
+ doc/systemd/monopd.service || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+ prepgamesdirs
+}