summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/imaze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/imaze')
-rw-r--r--games-fps/imaze/Manifest1
-rw-r--r--games-fps/imaze/imaze-1.4.ebuild55
-rw-r--r--games-fps/imaze/metadata.xml5
3 files changed, 61 insertions, 0 deletions
diff --git a/games-fps/imaze/Manifest b/games-fps/imaze/Manifest
new file mode 100644
index 000000000000..16335c61eea7
--- /dev/null
+++ b/games-fps/imaze/Manifest
@@ -0,0 +1 @@
+DIST imaze-1.4.tar.gz 649705 RMD160 01542e9987814475c5468547c93449fa81982499 SHA1 8e6d89a28014e1bc5c9a25d630c3d31a15f94f39 SHA256 2057b607d0a2872384d8a742fa9fac884fd9a03492733eb771cb1f85ff20528b
diff --git a/games-fps/imaze/imaze-1.4.ebuild b/games-fps/imaze/imaze-1.4.ebuild
new file mode 100644
index 000000000000..b50877f6c75c
--- /dev/null
+++ b/games-fps/imaze/imaze-1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit games
+
+DESCRIPTION="Multi player, real time, 3D, labyrinth, run & shoot game"
+HOMEPAGE="http://home.tu-clausthal.de/student/iMaze/"
+SRC_URI="http://home.tu-clausthal.de/student/iMaze/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE="joystick"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libXaw3d"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${P}/source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e s:'DEFINES=-DDEFAULT_SOUND_DIR=\\"`pwd`/../sounds\\"':\
+'DEFINES=-DDEFAULT_SERVER=\\"localhost\\" -DDEFAULT_SOUND_DIR=\\"${GAMES_DATADIR}/${PN}/sounds\\"': Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myconf="audio athena"
+
+ use joystick \
+ && myconf="${myconf} joystick" \
+ || myconf="${myconf} nojoystick"
+
+ # not an autoconf script.
+ ./configure ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin genlab imaze imazesrv imazestat ninja xlabed \
+ || die "dogamesbin failed"
+ dodoc ../README
+ doman ../man6/*6
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ../labs/ ../sounds/ || die "doins failed"
+ prepgamesdirs
+}
diff --git a/games-fps/imaze/metadata.xml b/games-fps/imaze/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/imaze/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>