summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-22 06:54:44 +0100
committerMichał Górny <mgorny@gentoo.org>2020-04-14 07:33:07 +0200
commit180fa85d7d00aea463c399f70348beaad9166eb7 (patch)
tree8b48c51a04cad103fb8451feec905a44d2c2dc89 /eclass/distutils-r1.eclass
parentpython-single-r1.eclass: Allow using PYTHON_USEDEP again (diff)
downloadgentoo-180fa85d7d00aea463c399f70348beaad9166eb7.tar.gz
gentoo-180fa85d7d00aea463c399f70348beaad9166eb7.tar.bz2
gentoo-180fa85d7d00aea463c399f70348beaad9166eb7.zip
distutils-r1.eclass: Pass --skip-build when installing
Explicitly pass --skip-build in order to prevent distutils from rebuilding files when installing. This is especially relevant to some packages that build extensions, and the extensions get built again in src_install(). Technically, this can break some customized build systems that write implementation-specific data into source directory, and right now the implied rebuild caused it to be rewritten when installing. With this patch, the newest version of the file would be installed for all interpreters. I am not aware of any such packages, though. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index fd6c0193d12e..51e99a009df1 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -873,7 +873,7 @@ distutils-r1_python_install() {
local root=${D%/}/_${EPYTHON}
[[ ${DISTUTILS_SINGLE_IMPL} ]] && root=${D%/}
- esetup.py install --root="${root}" "${args[@]}"
+ esetup.py install --skip-build --root="${root}" "${args[@]}"
local forbidden_package_names=( examples test tests .pytest_cache )
local p