summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-02-10 10:32:39 -0500
committerMike Frysinger <vapier@gentoo.org>2020-02-10 10:35:11 -0500
commit8008db53fdd68e204d91c9e3fcb87dbb1331f122 (patch)
treeaf10da7a57694e0ab1b141238b784aa1bc2c2a0b /dev-vcs
parentdev-vcs/repo: stablize 1.26 (diff)
downloadgentoo-8008db53fdd68e204d91c9e3fcb87dbb1331f122.tar.gz
gentoo-8008db53fdd68e204d91c9e3fcb87dbb1331f122.tar.bz2
gentoo-8008db53fdd68e204d91c9e3fcb87dbb1331f122.zip
dev-vcs/repo: version bump to 2.0
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index 71ea0be1a2eb..d1a316306844 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1 +1,2 @@
DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5db144b6ea3ec38a727238d7dc6e609a22edb5b84d350210564615016f6b36599cf9e3fc3b34ef9 SHA512 1398fab95b4fb4a24fda93d4054384a801b5b70e3dca3a794f458d8e19582ef833ef5a3a0f3a571121d2d9172ce0e70f8b3c6719f6c2f47643ffe6de181e34b4
+DIST repo-2.0 30067 BLAKE2B 23aaae97c8512e329a4293d82c4e65583861d515dc079fdddbb73473ea0aeb3951315fa7595c70695cf94f030ed2bc97b134ff2aafe774b552132ac8cf4f4045 SHA512 a83525fa87a3fba8d78af1305dd92f5e51f58430bff20f63b8b743ad94d382ecf3edc1888c78f9da4be4d379bfa3ccde79aae5c1d8c173f928d3593ea42156bb
diff --git a/dev-vcs/repo/repo-2.0.ebuild b/dev-vcs/repo/repo-2.0.ebuild
new file mode 100644
index 000000000000..1632716eecc8
--- /dev/null
+++ b/dev-vcs/repo/repo-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}