summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-07-16 12:32:21 +0200
committerDavid Seifert <soap@gentoo.org>2023-07-16 12:32:21 +0200
commit0d7bbf4999faf3efcdafe81fc8666d30a93f7a33 (patch)
treee74b4f623a7a42ae2e60bff1b22ea61d69ff204f /dev-util
parentnet-im/skypeforlinux: drop 8.97.0.404 (diff)
downloadgentoo-0d7bbf4999faf3efcdafe81fc8666d30a93f7a33.tar.gz
gentoo-0d7bbf4999faf3efcdafe81fc8666d30a93f7a33.tar.bz2
gentoo-0d7bbf4999faf3efcdafe81fc8666d30a93f7a33.zip
dev-util/b2: add 4.10.1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/b2/Manifest1
-rw-r--r--dev-util/b2/b2-4.10.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/b2/Manifest b/dev-util/b2/Manifest
index 7c4582d010e1..1bc47347caa7 100644
--- a/dev-util/b2/Manifest
+++ b/dev-util/b2/Manifest
@@ -1,2 +1,3 @@
DIST b2-4.10.0.tar.gz 982436 BLAKE2B 7e408e4ae67cf483c972fd7cefda39938c7819aa28e3ef358f44efe19ef43014d52fe32be40e27f33c27db760833948bbeb54e4ee99fd7ebb4e73e8ea3618c6b SHA512 251a3e07b18cbc768e7423d6259eec7466dfb33d2bab1e2f88bc0896574c854338429b591e6961c0d81c17b9ec6eb4cda06f46a8952f5ca4e4fa8bffb69a50d7
+DIST b2-4.10.1.tar.gz 982429 BLAKE2B bb1e6ef741ca10d3b0029e64d69a7ee7eb0d40d26c68d2a3932d4210e8e2a83131c9bac2d54f2885373725d58fe73dd7fa7aebfc5781059f01c3462c738d426c SHA512 0bc4897a342685190626a6593926c4b200c5ca9b498ba77287a7c49467a8e3f65cb850b9616fd05d4aea9ebfab32ec46792d7d8226bed89911a711ce14ecce30
DIST b2-4.9.6.tar.gz 977724 BLAKE2B 15ce459d7051be037bdb477432591baccb4e5339a16385a63205c19815766406f631879f0e1f986e184640466f5b6af5ade72d248975731528032a8e735e483e SHA512 a3dc9dccbf1221971607a15df642d4ad9029c1acaf329e419f363a6e6ddb6062a8ef595aa49810dc2ff3a3f333bfbaed7384819a143cc5847a95daf6fd48ccb1
diff --git a/dev-util/b2/b2-4.10.1.ebuild b/dev-util/b2/b2-4.10.1.ebuild
new file mode 100644
index 000000000000..84055fa002bc
--- /dev/null
+++ b/dev-util/b2/b2-4.10.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://www.bfgroup.xyz/b2/"
+SRC_URI="https://github.com/bfgroup/b2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+RDEPEND="!dev-util/boost-build"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.2-disable_python_rpath.patch
+ "${FILESDIR}"/${PN}-4.9.2-darwin-gentoo-toolchain.patch
+ "${FILESDIR}"/${PN}-4.9.2-add-none-feature-options.patch
+ "${FILESDIR}"/${PN}-4.9.2-no-implicit-march-flags.patch
+ "${FILESDIR}"/${PN}-4.9.2-odr.patch
+)
+
+src_configure() {
+ # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
+ append-lfs-flags
+}
+
+src_compile() {
+ cd engine || die
+
+ # upstream doesn't want separate flags for CPPFLAGS/LDFLAGS
+ # https://github.com/bfgroup/b2/pull/187#issuecomment-1335688424
+ edo ${CONFIG_SHELL:-${BASH}} ./build.sh cxx \
+ --cxx="$(tc-getCXX)" \
+ --cxxflags="${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ -d+2 \
+ --without-python
+}
+
+src_test() {
+ # Forget tests, b2 is a lost cause
+ :
+}
+
+src_install() {
+ dobin engine/b2
+
+ insinto /usr/share/b2/src
+ doins -r "${FILESDIR}/site-config.jam" \
+ bootstrap.jam build-system.jam ../example/user-config.jam \
+ build kernel options tools util
+
+ find "${ED}"/usr/share/b2/src -iname '*.py' -delete || die
+
+ dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+ if use examples; then
+ docinto examples
+ dodoc -r ../example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}