summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sel')
-rw-r--r--dev-util/sel/Manifest1
-rw-r--r--dev-util/sel/metadata.xml12
-rw-r--r--dev-util/sel/sel-0.08.4-r1.ebuild35
-rw-r--r--dev-util/sel/sel-0.08.4.ebuild45
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/sel/Manifest b/dev-util/sel/Manifest
new file mode 100644
index 000000000000..4c9cc95303db
--- /dev/null
+++ b/dev-util/sel/Manifest
@@ -0,0 +1 @@
+DIST sel-0.08.4.tar.gz 22188 SHA256 051279e3432415497d02c53e2fe9691b4039bfa6398fb1a60bb2603e1c94a66a SHA512 5550f1b78fef10c2ac7c132f752db4e0f7a3318419bf5751a4f812c1da04b07b3fcac341076d32f6ea436a0216ad6746e9cf29c4bcef630b76e307ded6237e52 WHIRLPOOL 76d92e6d99260f40d633d975204cdcf17999566e268b202d5dce1e2ed809a195ecfbd965f2e90c9a416b1bb3f31d0246e4d394fca7dd824528a1d77f57cc97f6
diff --git a/dev-util/sel/metadata.xml b/dev-util/sel/metadata.xml
new file mode 100644
index 000000000000..b85f8c3dbf42
--- /dev/null
+++ b/dev-util/sel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+sel is a file selection utility for use on the shell and in shell scripts
+</longdescription>
+</pkgmetadata>
diff --git a/dev-util/sel/sel-0.08.4-r1.ebuild b/dev-util/sel/sel-0.08.4-r1.ebuild
new file mode 100644
index 000000000000..81da6fc2c26a
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc s390 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.1"
+DEPEND="${RDEPEND}"
+
+src_prepare () {
+ sed -i -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ sel.c || die 'sed failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+}
+
+src_install () {
+ dobin sel
+ doman sel.1
+ insinto /usr/share/sel
+ doins help.txt
+ dodoc README.GER
+}
diff --git a/dev-util/sel/sel-0.08.4.ebuild b/dev-util/sel/sel-0.08.4.ebuild
new file mode 100644
index 000000000000..41dd52876162
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc s390 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.1"
+DEPEND="${RDEPEND}"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ sel.c || die 'sed failed'
+}
+
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ doecho $(tc-getCC) -o ${PN} \
+ ${CFLAGS} ${LDFLAGS} \
+ ${PN}.c -lncurses \
+ || die "build failed"
+}
+
+src_install () {
+ dobin sel || die
+ doman sel.1 || die
+ insinto /usr/share/sel
+ doins help.txt || die
+ dodoc README.GER || die
+}