summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-28 23:40:42 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-29 00:47:01 +0200
commit4442e3e66d8459aeaaaa33afaa263a5a9c2b9c55 (patch)
treeefe6f78872d2d849d45c1a327cba3f0ad3896a59 /dev-util/colm
parentdev-libs/libmcrypt: Fixes from Fedora and drop .la files (diff)
downloadgentoo-4442e3e66d8459aeaaaa33afaa263a5a9c2b9c55.tar.gz
gentoo-4442e3e66d8459aeaaaa33afaa263a5a9c2b9c55.tar.bz2
gentoo-4442e3e66d8459aeaaaa33afaa263a5a9c2b9c55.zip
dev-util/colm: Drop .la files and fix sed delimiter for CFLAGS
Closes: https://bugs.gentoo.org/840966 Closes: https://bugs.gentoo.org/840969 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-util/colm')
-rw-r--r--dev-util/colm/colm-0.14.7-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/colm/colm-0.14.7-r2.ebuild b/dev-util/colm/colm-0.14.7-r2.ebuild
new file mode 100644
index 000000000000..23a2f43b338a
--- /dev/null
+++ b/dev-util/colm/colm-0.14.7-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="COmputer Language Manipulation"
+HOMEPAGE="https://www.colm.net/open-source/colm/"
+SRC_URI="https://www.colm.net/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+BDEPEND="
+ doc? (
+ || ( app-text/asciidoc dev-ruby/asciidoctor )
+ dev-python/pygments
+ )
+"
+# libfsm moved from ragel -> colm, bug #766108
+RDEPEND="!<dev-util/ragel-7.0.3"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.7-drop-julia-check.patch
+ "${FILESDIR}"/${PN}-0.14.7-disable-static-lib.patch
+ "${FILESDIR}"/${PN}-0.14.7-solaris.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #733426
+ sed -i -e 's/(\[ASCIIDOC\], \[asciidoc\], \[asciidoc\]/S([ASCIIDOC], [asciidoc asciidoctor]/' configure.ac || die
+
+ # bug #766069
+ sed -i -e "s|gcc|$(tc-getCC) ${CFLAGS}|" src/main.cc || die
+ sed -i -e "s|gcc|$(tc-getCC)|" test/colm.d/gentests.sh || die
+ sed -i -e "s|g++|$(tc-getCXX)|" test/colm.d/gentests.sh || die
+
+ # fix linkage on Darwin from colm itself during build
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/libcolm\.so/libcolm.dylib/' src/main.cc || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc manual)
+}
+
+src_test() {
+ # Build tests
+ default
+
+ # Run them
+ cd test || die
+ ./runtests || die
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}