summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-01-30 17:06:54 -0700
committerChristoph Junghans <ottxor@gentoo.org>2016-02-06 15:32:30 -0700
commit2c66669c2ee4171225690aa57b7c2162afdbadf3 (patch)
tree69639259150cd9dba22b7828b7fc0c71879d5064 /dev-ruby/pusher-client/pusher-client-0.6.2.ebuild
parentapp-emulation/grub-xen-host: initial version (diff)
downloadgentoo-2c66669c2ee4171225690aa57b7c2162afdbadf3.tar.gz
gentoo-2c66669c2ee4171225690aa57b7c2162afdbadf3.tar.bz2
gentoo-2c66669c2ee4171225690aa57b7c2162afdbadf3.zip
dev-ruby/pusher-client: initial commit
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/pusher-client/pusher-client-0.6.2.ebuild')
-rw-r--r--dev-ruby/pusher-client/pusher-client-0.6.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/pusher-client/pusher-client-0.6.2.ebuild b/dev-ruby/pusher-client/pusher-client-0.6.2.ebuild
new file mode 100644
index 000000000000..ad1eb2429b7a
--- /dev/null
+++ b/dev-ruby/pusher-client/pusher-client-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Client for consuming WebSockets from http://pusher.com"
+HOMEPAGE="https://github.com/pusher-community/pusher-websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/websocket-1:0
+ dev-ruby/json
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}