summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-10 07:14:57 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-10 07:14:57 +0100
commit09efc550798d30afa5673b9227e015d6217d6fb0 (patch)
tree5195fff5f56a7438f0c20bcf8d2a00922ba51c5b /dev-ruby/pkg-config
parentdev-ruby/ox: add 2.13.2 (diff)
downloadgentoo-09efc550798d30afa5673b9227e015d6217d6fb0.tar.gz
gentoo-09efc550798d30afa5673b9227e015d6217d6fb0.tar.bz2
gentoo-09efc550798d30afa5673b9227e015d6217d6fb0.zip
dev-ruby/pkg-config: add 1.4.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest1
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index e344fc2fb59a..559fcfb9c46f 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,3 +1,4 @@
DIST pkg-config-1.2.8.gem 20480 BLAKE2B cc11b5eff30f0f5e1a91e64902931ed540da108fd326fe731b71527c9c4310f55e9002617e1baae4f71a4b705b20cf10f6fa112f8ef56971e82868145d372a47 SHA512 d83a599a48c7d404946054c6846b6cfd9fce2a264c288519a6eccd9787f05d45397dd46300bf97c80700921456318154ea6d44ba32cd159803471073c2a2b065
DIST pkg-config-1.3.9.gem 22016 BLAKE2B bb22881e07a251722e5e2344a8ebfea105456c4994da01b6cad53b93c5fab515537c04166be9985bac224944e89506040a2f89886f03c9f5d9c2227551e6e840 SHA512 ffec47956f59daea7eefe749474389cc43b500251b7d35cf268caed975d4b8483990c6c5cc0eb1cb918a7e09edd483fe88d6e7141c13496edeb4d4aac5ab3019
DIST pkg-config-1.4.0.gem 22016 BLAKE2B a9f56e68580b290bc0b09b07dc059b5ac7141a97a2a4653529fd59aa348bee7ce90a2e752172d2d0f376b67fbb7253f0d3bb38107eb68e3d6bb3f7d57637423c SHA512 d60539519e86e210def73d2536a694e2fc7a6a424c7cdd49b6046420b113520465e1863ef4d90d9491d081b78e16cfff27121d3b7f78a78330c4a242c652ebd7
+DIST pkg-config-1.4.1.gem 22016 BLAKE2B efac610221b288bb669a3783c0e70af3951478147896315c53af2186912b60045096c0ba01a0a59ce09897a2e4e747d28a091b947281fe7f6dd6f85cea31aae7 SHA512 72d61466c1ea53a5eda66a8e8f8106fef0269fefdd349ac83959a34bb8f36796bd3e9c7fbcbad5763d2fca015c65436f9d410724e27b6d1c495e3957d26757a6
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.1.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.1.ebuild
new file mode 100644
index 000000000000..b79bc3efa0bf
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}