summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-28 18:24:44 +0200
committerHans de Graaff <graaff@gentoo.org>2023-03-28 18:25:32 +0200
commit0595fbd3de862b715a3da2cd6e34351b19e78552 (patch)
treef20e4c4c20ef4b9d9ff7e17fb5df9d0811c7ebfe /dev-ruby/execjs
parentdev-ruby/mustache: Stabilize 1.1.1-r1 sparc, #903283 (diff)
downloadgentoo-0595fbd3de862b715a3da2cd6e34351b19e78552.tar.gz
gentoo-0595fbd3de862b715a3da2cd6e34351b19e78552.tar.bz2
gentoo-0595fbd3de862b715a3da2cd6e34351b19e78552.zip
dev-ruby/execjs: update EAPI 7 -> 8, add ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/execjs')
-rw-r--r--dev-ruby/execjs/execjs-2.8.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/execjs/execjs-2.8.1-r1.ebuild b/dev-ruby/execjs/execjs-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..c7be19c05ace
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.8.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/rails/execjs"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+RDEPEND+=" || ( dev-ruby/duktape-rb net-libs/nodejs )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}