summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-26 09:27:58 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-26 09:47:52 +0200
commit0a67f3a8a66f8394dca314e1650bf9137dbc5067 (patch)
tree59408e28f12088029050b7fb9a5b218e60947e83 /dev-ruby/actionview
parentdev-ruby/activerecord: add 6.1.7.10 (diff)
downloadgentoo-0a67f3a8a66f8394dca314e1650bf9137dbc5067.tar.gz
gentoo-0a67f3a8a66f8394dca314e1650bf9137dbc5067.tar.bz2
gentoo-0a67f3a8a66f8394dca314e1650bf9137dbc5067.zip
dev-ruby/actionview: add 6.1.7.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/Manifest1
-rw-r--r--dev-ruby/actionview/actionview-6.1.7.10.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ruby/actionview/Manifest b/dev-ruby/actionview/Manifest
index 4086f4650837..046023b83751 100644
--- a/dev-ruby/actionview/Manifest
+++ b/dev-ruby/actionview/Manifest
@@ -1,3 +1,4 @@
+DIST rails-6.1.7.10.tgz 11034185 BLAKE2B 569fcde5a788151af1eb1bfe7a83048e92bdca36a3e219848567aec47877d17d791ba9f5e4913e077d458e52e7a6b69d448e1763b68e8284b9de4d2a60feaaab SHA512 ae601abca73cb6b962a9863fece1bca2e9ab64ef884054df58ec51cbc8256e9dc26086ade7c0c24c37a2047fd9f21f121ac22b44384bcd877df1d300aa06fe79
DIST rails-6.1.7.8.tgz 11041890 BLAKE2B 285571972ec1d43ae65f3c4f586679e31d0550263c4778925c5828000d6ba971a791ad1071a7ab5edd8d728cd51ee15bb5cee1261b828a4b5926a54f34887d10 SHA512 8c819da0f46820f05d4128444fb3c3908d5e50f97935b173cdd156a986720dda6bcbb62015884d3142ebd5b17621e3f94ca2c80691564914088e884b9aac3573
DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67bded2801ce54872f7cef80fb75120f56b356940a44d943cbd05b4d63778726885ac20dd04a2e5510f54ea06ac SHA512 387cbc5424b16ade97091e3cfc3a5bc0cfe277ee75a7f35cdf5d393c692d2ea17f258e38d8b25c8c8a1be4fb64a39d0f675b23942145929bb7be4783cd95d90b
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
diff --git a/dev-ruby/actionview/actionview-6.1.7.10.ebuild b/dev-ruby/actionview/actionview-6.1.7.10.ebuild
new file mode 100644
index 000000000000..d27d6951c94f
--- /dev/null
+++ b/dev-ruby/actionview/actionview-6.1.7.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
+ >=dev-ruby/erubi-1.4:0
+ >=dev-ruby/rails-html-sanitizer-1.2.0:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/railties-${PV}
+ dev-ruby/sqlite3
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|rack-cache\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|mime-types\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ sed -e '3igem "railties", "~> 6.1.0"; gem "activerecord", "~> 6.1.0"; gem "minitest", "<5.16"; require "ostruct"' \
+ -i test/abstract_unit.rb || die
+
+ # Fix loading of activerecord integration tests. This avoids loading
+ # activerecord twice and thus redefining constants leading to
+ # failures. Bug #719342
+ sed -e '/abstract_unit/arequire "active_record" ; require "active_record/fixtures"' \
+ -e '/defined/ s/FixtureSet/ActiveRecord::FixtureSet/' \
+ -i test/active_record_unit.rb || die
+
+ # Avoid test failing on capitalization difference
+ sed -e '/test_raise_arg_overrides_raise_config_option/askip "Capitalization difference"' \
+ -i test/template/translation_helper_test.rb || die
+
+ # Remove tests that are coupled to the Sanitizer (already removed upstream)
+ sed -e '/test_sanitized_allowed_\(tags_class_method\|attributes_class_method\)/askip "Removed upstream"' \
+ -i test/template/sanitize_helper_test.rb || die
+}