summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 13:49:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 13:49:55 +0200
commit0493a99bfe0bf05bfa97f4d4094c75fb7d2a7c7b (patch)
tree9ede66ebe8dbfaad58ab66843c7b406495db8b3c /dev-ros/rosbuild
parentdev-ros/rosboost_cfg: This is a python package, so set PYTHON_COMPAT. (diff)
downloadgentoo-0493a99bfe0bf05bfa97f4d4094c75fb7d2a7c7b.tar.gz
gentoo-0493a99bfe0bf05bfa97f4d4094c75fb7d2a7c7b.tar.bz2
gentoo-0493a99bfe0bf05bfa97f4d4094c75fb7d2a7c7b.zip
dev-ros/rosbuild: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosbuild')
-rw-r--r--dev-ros/rosbuild/Manifest1
-rw-r--r--dev-ros/rosbuild/metadata.xml5
-rw-r--r--dev-ros/rosbuild/rosbuild-1.12.3.ebuild19
-rw-r--r--dev-ros/rosbuild/rosbuild-9999.ebuild19
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-ros/rosbuild/Manifest b/dev-ros/rosbuild/Manifest
new file mode 100644
index 000000000000..02c7ccc4a2ae
--- /dev/null
+++ b/dev-ros/rosbuild/Manifest
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/rosbuild/metadata.xml b/dev-ros/rosbuild/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosbuild/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosbuild/rosbuild-1.12.3.ebuild b/dev-ros/rosbuild/rosbuild-1.12.3.ebuild
new file mode 100644
index 000000000000..9b8ca353c35c
--- /dev/null
+++ b/dev-ros/rosbuild/rosbuild-1.12.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Scripts for managing the CMake-based build system for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosbuild/rosbuild-9999.ebuild b/dev-ros/rosbuild/rosbuild-9999.ebuild
new file mode 100644
index 000000000000..9b8ca353c35c
--- /dev/null
+++ b/dev-ros/rosbuild/rosbuild-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Scripts for managing the CMake-based build system for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"