summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-18 00:20:32 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-18 00:21:24 +0000
commitdc8eac15691012571ae9baf3bdcc5bc729585875 (patch)
tree52f5108d60e6904d7a3419e91e958e725d1ce799 /dev-python
parentdev-ruby/classifier-reborn: Version bump (diff)
downloadgentoo-dc8eac15691012571ae9baf3bdcc5bc729585875.tar.gz
gentoo-dc8eac15691012571ae9baf3bdcc5bc729585875.tar.bz2
gentoo-dc8eac15691012571ae9baf3bdcc5bc729585875.zip
dev-python/netcdf4-python: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/netcdf4-python/Manifest1
-rw-r--r--dev-python/netcdf4-python/metadata.xml9
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild34
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/netcdf4-python/Manifest b/dev-python/netcdf4-python/Manifest
index 4c6560d961ac..e894b2c2f8d6 100644
--- a/dev-python/netcdf4-python/Manifest
+++ b/dev-python/netcdf4-python/Manifest
@@ -1 +1,2 @@
DIST netCDF4-1.0.4.tar.gz 521990 SHA256 99f5eaebae2fae92759d13b790dde4226b2b8c83a68f86543c41c7998cba53b7 SHA512 acebb8b721720fae8ae8347ac10b3bc213cbc6db763001292ab99db56fc20fd82abc17d5449ad8d75f40edb5bf14f24b0bece725671fcc15bf3b0cb6580c46c5 WHIRLPOOL d664d2a187b5191275bdc6fd6a456b684b4c9b1c6c0249e0299ba15ec10a6433b0859f84bf26148a7ca392e307a40f4bdfd13a7dc7ff8b059d8471f18e939b16
+DIST netCDF4-1.2.2.tar.gz 679107 SHA256 5e68d0a723ed327e53e90ac73d3dfa25e8da10db9ffba5f2aefd61356722ae9d SHA512 e09465d125077e71b8aad4332be844099c7fa29d0ea8f1dd0887f7a5e849ab778361026323466b1d4897bc3d8f8be1818cfa5f426773c765ee9c5f3728ff3da3 WHIRLPOOL 8fc551fbe6e1628304dd5067a22bbaffbb336c68f8315d5e929927f6ad52b0974b7a412d019b87a65e621e49d720ff1570514af66345e6c46c501ca9d862761e
diff --git a/dev-python/netcdf4-python/metadata.xml b/dev-python/netcdf4-python/metadata.xml
index 4fbf56dbfcf6..b230a3c11bf8 100644
--- a/dev-python/netcdf4-python/metadata.xml
+++ b/dev-python/netcdf4-python/metadata.xml
@@ -5,7 +5,14 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <longdescription>
+ netcdf4-python is a Python interface to the netCDF C library.
+ netCDF version 4 can read and write files in both the new netCDF 4
+ and the old netCDF 3 format, and can create files that are readable
+ by HDF5 clients. The API modelled after Scientific.IO.NetCDF, and
+ should be familiar to users of that module.
+ </longdescription>
<upstream>
- <remote-id type="github">Unidata/netcdf4-python</remote-id>
+ <remote-id type="pypi">netCDF4</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild
new file mode 100644
index 000000000000..65825e4d2255
--- /dev/null
+++ b/dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+MY_PN="netCDF4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="http://unidata.github.io/netcdf4-python"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy
+ sci-libs/hdf5
+ sci-libs/netcdf:=[hdf,hdf5]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ cd test || die
+ ${PYTHON} run_all.py || die
+}