summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-13 21:27:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-13 21:27:50 +0100
commit7a6b97198854d0e6889ea8f14137ed99777641bd (patch)
tree92e1674432613db6dc9324c3443295811bc9deca /dev-python
parentdev-python/botocore: Remove old (diff)
downloadgentoo-7a6b97198854d0e6889ea8f14137ed99777641bd.tar.gz
gentoo-7a6b97198854d0e6889ea8f14137ed99777641bd.tar.bz2
gentoo-7a6b97198854d0e6889ea8f14137ed99777641bd.zip
dev-python/pyqtgraph: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyqtgraph/Manifest1
-rw-r--r--dev-python/pyqtgraph/files/pyqtgraph-0.12.2-fix-py3.10.patch46
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild94
3 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 0c35eeb730d1..b8e7cc7a640f 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,3 +1,2 @@
-DIST pyqtgraph-0.12.2.tar.gz 1292676 BLAKE2B af5e61bbc7f55cda669825a9742a3f2424638d35e3a10b85b7fc635a5e40b630848bed1e88bc84383cbd3e85de538b1b1fa051d6d761b368209c1d8167f55a2a SHA512 8a7f0e1e78cf147568ee6e393a07f07301632765d1bdb50328fcf1f815dda76f3e89808cef945409dcd9142407f864f205778a76cf804d4cbce544c60bcf5042
DIST pyqtgraph-0.12.3.tar.gz 1317230 BLAKE2B d9a7a86f976fd7d778b0f038b24e80d6cbbdb98f6cda7de0461d1e3bbac0a99745dc3cccc63f38c24128018a2f41f3a0da7437bf9ddbd3f4091fd826ae4ea915 SHA512 13f1ff4bcce7ab8c133ebb99101d300bb3abcd6ea8b7321f3aa646d6992b6988db17d478dcec52339dd380f7c6e487f47b95b9f9de616b7ff2dab35ca5f0cc30
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
diff --git a/dev-python/pyqtgraph/files/pyqtgraph-0.12.2-fix-py3.10.patch b/dev-python/pyqtgraph/files/pyqtgraph-0.12.2-fix-py3.10.patch
deleted file mode 100644
index bb1e4a8a766a..000000000000
--- a/dev-python/pyqtgraph/files/pyqtgraph-0.12.2-fix-py3.10.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From db8180d88ed37425467d030bebf7792c86691b83 Mon Sep 17 00:00:00 2001
-From: Scott Talbert <swt@techie.net>
-Date: Sun, 11 Jul 2021 22:04:00 -0400
-Subject: [PATCH] Fix GLTextItem with Python 3.10
-
-drawText() expects int arguments and Python 3.10 does not allow for
-implicit rounding.
-
---- a/pyqtgraph/opengl/items/GLTextItem.py
-+++ b/pyqtgraph/opengl/items/GLTextItem.py
-@@ -68,15 +68,15 @@ def paint(self):
- viewport = glGetIntegerv(GL_VIEWPORT)
-
- text_pos = self.__project(self.pos, modelview, projection, viewport)
-- text_pos[1] = viewport[3] - text_pos[1]
-
-+ text_pos.setY(viewport[3] - text_pos.y())
- text_pos /= self.view().devicePixelRatio()
-
- painter = QtGui.QPainter(self.view())
- painter.setPen(self.color)
- painter.setFont(self.font)
- painter.setRenderHints(QtGui.QPainter.RenderHint.Antialiasing | QtGui.QPainter.RenderHint.TextAntialiasing)
-- painter.drawText(text_pos[0], text_pos[1], self.text)
-+ painter.drawText(text_pos, self.text)
- painter.end()
-
- def __project(self, obj_pos, modelview, projection, viewport):
-@@ -86,12 +86,11 @@ def __project(self, obj_pos, modelview, projection, viewport):
- proj_vec = np.matmul(projection.T, view_vec)
-
- if proj_vec[3] == 0.0:
-- return
-+ return QtCore.QPointF(0, 0)
-
- proj_vec[0:3] /= proj_vec[3]
-
-- return np.array([
-- viewport[0] + (1.0 + proj_vec[0]) * viewport[2] / 2.0,
-- viewport[1] + (1.0 + proj_vec[1]) * viewport[3] / 2.0,
-- (1.0 + proj_vec[2]) / 2.0
-- ])
-+ return QtCore.QPointF(
-+ viewport[0] + (1.0 + proj_vec[0]) * viewport[2] / 2,
-+ viewport[1] + (1.0 + proj_vec[1]) * viewport[3] / 2
-+ )
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
deleted file mode 100644
index c6366f824b79..000000000000
--- a/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 multiprocessing
-
-TEST_DATA_TAG=test-data-8
-DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
-HOMEPAGE="https://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
-SRC_URI="
- https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
- test? (
- https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
- -> ${PN}-${TEST_DATA_TAG}.tar.gz
- )"
-S=${WORKDIR}/${PN}-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples opengl svg"
-REQUIRED_USE="test? ( opengl svg )"
-
-RDEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? (
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytest-xvfb[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if ! use opengl; then
- rm -r pyqtgraph/opengl || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # apparently fragile
- tests/test_reload.py::test_reload
-
- # TODO
- tests/graphicsItems/test_ROI.py::test_PolyLineROI
-
- # pyside2 is normally skipped if not installed but these two
- # fail if it is installed
- # TODO: this could be due to USE flags, revisit when pyside2
- # gains py3.9
- 'examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
- 'examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
- )
-
- distutils_install_for_testing
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-src_test() {
- mkdir "${HOME}"/.pyqtgraph || die
- mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
- "${HOME}"/.pyqtgraph/test-data || die
- cd "${HOME}"/.pyqtgraph/test-data || die
- # we need to fake a git repo
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git init -q || die
- git commit -q --allow-empty -m "dummy commit" || die
- git tag "${TEST_DATA_TAG}" || die
- cd - >/dev/null || die
-
- distutils-r1_src_test
-}
-
-python_install_all() {
- use examples && DOCS+=( examples/ )
- distutils-r1_python_install_all
-}