summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 14:04:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 14:04:54 +0100
commit19db733f00bdcf3cbae7b929b1d4ccda74c072c5 (patch)
tree82f472f5c2b224bb3aff9967cea5f8d1cbabfe65 /dev-python
parentdev-python/lit: Remove 17.0.4.9999 (live) (diff)
downloadgentoo-19db733f00bdcf3cbae7b929b1d4ccda74c072c5.tar.gz
gentoo-19db733f00bdcf3cbae7b929b1d4ccda74c072c5.tar.bz2
gentoo-19db733f00bdcf3cbae7b929b1d4ccda74c072c5.zip
dev-python/clang-python: Remove 17.0.4.9999 (live)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/clang-python/clang-python-17.0.4.9999.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/clang-python/clang-python-17.0.4.9999.ebuild b/dev-python/clang-python/clang-python-17.0.4.9999.ebuild
deleted file mode 100644
index e1394f43bcd1..000000000000
--- a/dev-python/clang-python/clang-python-17.0.4.9999.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit llvm.org python-r1
-
-DESCRIPTION="Python bindings for sys-devel/clang"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# The module is opening libclang.so directly, and doing some blasphemy
-# on top of it.
-DEPEND="
- >=sys-devel/clang-${PV}:*
- !sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
-"
-RDEPEND="
- ${DEPEND}
- ${PYTHON_DEPS}
-"
-BDEPEND="
- ${PYTHON_DEPS}
- test? (
- sys-devel/clang:${LLVM_MAJOR}
- )
-"
-
-LLVM_COMPONENTS=( clang/bindings/python )
-llvm.org_set_globals
-
-python_test() {
- # tests rely on results from a specific clang version, so override
- # the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
- local -x CLANG_NO_DEFAULT_CONFIG=1
- "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- python_foreach_impl python_test
-}
-
-src_install() {
- python_foreach_impl python_domodule clang
-}