summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-25 21:41:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-25 21:43:08 +0100
commit46454733157f867e03e1cde4c381310f3b39346c (patch)
treeb9fc26c0613b6702c86954348083d93020b4716c /dev-python
parentdev-python/tqdm: Add a dep on pytest-timeout (diff)
downloadgentoo-46454733157f867e03e1cde4c381310f3b39346c.tar.gz
gentoo-46454733157f867e03e1cde4c381310f3b39346c.tar.bz2
gentoo-46454733157f867e03e1cde4c381310f3b39346c.zip
dev-python/bpython: Bump to 0.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.21.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 68f1f88354c6..9635173bd57c 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1 +1,2 @@
DIST bpython-0.20.1.tar.gz 223953 BLAKE2B b26ee6e4d41609e9a04a013d90f4ae7f598ba28028d9982a77aa7f11887a60c39855e875ae004b416e375b0c906e066a22a18f0251d2e7192d690fe03afe51c7 SHA512 ff69b175afbb1f050f1aa481966bbc32580b3d113a886f49a97fa8f01e3c8c0edf2c0075785fc61ac616168c97d61ee7daeed85d0b08f1317fb774f7ad6bf439
+DIST bpython-0.21.tar.gz 208206 BLAKE2B 22db7abe3786df337af50f6217fa8c6702871b50de41245797270e70622084a22b3d6615cfe634044599a532c5bc14677b01dc77042d228213eaae2cad11b623 SHA512 a0eea1b9c2329ce5665456e99703ef476faab38f880eb8a330a6536970888cfdaada9f0e377d3c1acd8b6c79eb0c562ada43e82bac9df4cce5878594c3399ddf
diff --git a/dev-python/bpython/bpython-0.21.ebuild b/dev-python/bpython/bpython-0.21.ebuild
new file mode 100644
index 000000000000..4625638f76d2
--- /dev/null
+++ b/dev-python/bpython/bpython-0.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.3.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ "
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest