summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-20 23:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-21 00:04:02 +0200
commit3749f2be32f9c01e45f8eabe40348d77586afff7 (patch)
tree6f1ed7b5fc133166fd4c3baa44895ab5e951390b /dev-python
parentdev-lang/python: Move readline dep outside 'ncurses?' (diff)
downloadgentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.tar.gz
gentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.tar.bz2
gentoo-3749f2be32f9c01e45f8eabe40348d77586afff7.zip
dev-python/subvertpy: Bump to 0.10.1
Closes: https://bugs.gentoo.org/631214
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/subvertpy/Manifest1
-rw-r--r--dev-python/subvertpy/subvertpy-0.10.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/subvertpy/Manifest b/dev-python/subvertpy/Manifest
index e2e5b5a4ba9a..946d0a8c0ae3 100644
--- a/dev-python/subvertpy/Manifest
+++ b/dev-python/subvertpy/Manifest
@@ -1 +1,2 @@
+DIST subvertpy-0.10.1.tar.gz 116661 BLAKE2B 81fdc21352f168c1a8d31398be21ad83ed72adc824dbbca7764fb1836cba4a7d7f03e4a96636ab29f4804682658ce834eea3fd433b5f161e61a702dfc6790e22 SHA512 083174ca6516541c48474673e6d601ff3098f19d204f311101f4de81bcd70d73bdb1e73dffe43fc584f35d286020cab1381dc1c44b514442735a139d2a9cd356
DIST subvertpy-0.9.1.tar.gz 110972 BLAKE2B 1f11b55b81705b6b144e0c4ac53f2e0e5a847b96bb43589894c8c910492b443d61bfc5bdcbdba1e2bb757fbd587b029d0be113084a45c17aec8c0befdff0e12a SHA512 977e291c011e680cff9e26312b4235c0479374076964c7c4a4c3c7ec75bcc44ff7c458513ab89f1aa2b599d3bd8f94cbc6d1000afcf725a9f937a90b39456148
diff --git a/dev-python/subvertpy/subvertpy-0.10.1.ebuild b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
new file mode 100644
index 000000000000..903366b9f458
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="https://jelmer.uk/code/subvertpy/ https://pypi.org/project/subvertpy"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ dev-libs/apr-util"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test --args=-v
+}