summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-22 04:55:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-22 05:11:01 +0200
commitad59bf857e5790581b08ba1f81b8a6b9df51140b (patch)
treec33ba312371c7ce7a991e6fe0b1b8b77787330d5 /dev-python/xmlschema
parentdev-python/pydantic-core: Bump to 2.10.0 (diff)
downloadgentoo-ad59bf857e5790581b08ba1f81b8a6b9df51140b.tar.gz
gentoo-ad59bf857e5790581b08ba1f81b8a6b9df51140b.tar.bz2
gentoo-ad59bf857e5790581b08ba1f81b8a6b9df51140b.zip
dev-python/xmlschema: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-2.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 58bd88b44a62..87c01ce0e341 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-2.3.1.tar.gz 494834 BLAKE2B 2438a57f0b07aa5b0f9871bd6a4f64a90a7946ef3deb89b8e12736c52f185a3f4406ff5e894cd7b330600f82e55f6470a32769ed06e4ce85e914dc9808d5091c SHA512 6a08db7cc8f719f2b6d2b8c8478aa35b4fae72bd3c595a2ac9d39c6be6f75a3cdbf696f9e7424d3122d618a4bffc6bfddd5600daa8e0a64db5474fe95659c706
+DIST xmlschema-2.5.0.tar.gz 539358 BLAKE2B 3d70b01f325ed1b4b61b1baaf1d7d29fd9748984f229d78bc645fef331d2cfb6f6d6e52200295ced0e03513e105ebfb8f30937c51e0883ee5d67866346cddb02 SHA512 d859be35d057d8bb1cea85c0f90525ae26f78f09ba2a111414f429eb2afd8633cb59ec0d701bba5bd1d086efb7ae51c2c470882cbfb932caa51c8b8d1ecbfbcb
diff --git a/dev-python/xmlschema/xmlschema-2.5.0.ebuild b/dev-python/xmlschema/xmlschema-2.5.0.ebuild
new file mode 100644
index 000000000000..0d98d02ad092
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-2.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.1.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}