summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:13:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:17 +0200
commitc3f35bbf269a21f8fb0a17c44ba4821e150deb8a (patch)
tree1e0fcb92ebfcb17e65908fc9aa67879e9f03aa14 /dev-python/uri_template
parentdev-python/jsonpointer: Bump to 2.3 (diff)
downloadgentoo-c3f35bbf269a21f8fb0a17c44ba4821e150deb8a.tar.gz
gentoo-c3f35bbf269a21f8fb0a17c44ba4821e150deb8a.tar.bz2
gentoo-c3f35bbf269a21f8fb0a17c44ba4821e150deb8a.zip
dev-python/uri_template: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uri_template')
-rw-r--r--dev-python/uri_template/Manifest1
-rw-r--r--dev-python/uri_template/uri_template-1.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/uri_template/Manifest b/dev-python/uri_template/Manifest
index d1d4d726f52a..687bf0c895a0 100644
--- a/dev-python/uri_template/Manifest
+++ b/dev-python/uri_template/Manifest
@@ -1 +1,2 @@
DIST uri_template-v1.1.0.tar.gz 18014 BLAKE2B 01ac4439b6661d0d1e7adb5b5ebcc594497cdaeef24b33cbfc8a26f607e779a72ae20838dbbcce28278886c87df475adfd53c73287a4768d848f65b95ba2ce58 SHA512 b6d34931e750acc6c160e7157fc000984acc099023e9794163777679cbe706b8a646bab89e82171c0318827b7a7b9cfcfb997768120cabcf36e7982214321665
+DIST uri_template-v1.2.0.tar.gz 18284 BLAKE2B cf857ccd8496111f61fb95af020514f1c484e5c3ff19829f28bc2dc112887fe276dac68aa21e0d092d42a22319e8d6ac8aff95c734aadd8417c56f57b0076256 SHA512 81b046bbc2dc4d5c0b40a76f13713c10e69d803e3d9da13ab69cc6d40569ef0a39c786a6637a66651a5c3d3e68807f923ad48a7feaf898ae3ca6fd03c0e68c37
diff --git a/dev-python/uri_template/uri_template-1.2.0.ebuild b/dev-python/uri_template/uri_template-1.2.0.ebuild
new file mode 100644
index 000000000000..2aa659f49c57
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="https://gitlab.linss.com/open-source/uri_template/"
+SRC_URI="https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
+}