summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-16 07:52:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-16 07:52:52 +0300
commit3de461054835faab4152664305c18bfa878f0517 (patch)
tree14026d13d57ae0bad5338ee08cf8737353f8c3c3 /dev-python/txaio
parentdev-python/sphinx-notfound-page: enable py3.10 (diff)
downloadgentoo-3de461054835faab4152664305c18bfa878f0517.tar.gz
gentoo-3de461054835faab4152664305c18bfa878f0517.tar.bz2
gentoo-3de461054835faab4152664305c18bfa878f0517.zip
dev-python/txaio: enable py3.10, add optfeature
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/txaio-21.2.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/txaio/txaio-21.2.1.ebuild b/dev-python/txaio/txaio-21.2.1.ebuild
index 0ae1647e9e78..edb1de4360cf 100644
--- a/dev-python/txaio/txaio-21.2.1.ebuild
+++ b/dev-python/txaio/txaio-21.2.1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
@@ -24,9 +24,12 @@ distutils_enable_sphinx docs \
'>=dev-python/sphinx_rtd_theme-0.1.9'
distutils_enable_tests pytest
-src_prepare() {
- default_src_prepare
+EPYTEST_DESELECT=(
# Take out failing tests known to pass when run manually
# we certainly don't need to test "python setup.py sdist" here
- rm "${S}/test/test_packaging.py" || die
+ test/test_packaging.py
+)
+
+pkg_postinst() {
+ optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
}