summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-27 18:45:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-27 18:48:44 +0200
commitfd10d5fef82557ea9b550c19f5805266069859da (patch)
treebda68d34a792a1815e56f34a8079a87727d00d78 /dev-python/tomlkit
parentdev-python/rich: Bump to 13.3.3 (diff)
downloadgentoo-fd10d5fef82557ea9b550c19f5805266069859da.tar.gz
gentoo-fd10d5fef82557ea9b550c19f5805266069859da.tar.bz2
gentoo-fd10d5fef82557ea9b550c19f5805266069859da.zip
dev-python/tomlkit: Bump to 0.11.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 4437634f1971..3312e8b2e158 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.11.6.tar.gz 188290 BLAKE2B c0fc64177dff2254ab4d377f15bada1093e69ed66f815b04f698359f096b123b256949e871344276e6fcda26e43ac22c505460c4f906505ea9676774cbfb0c5f SHA512 692f2facb18440609b63995f690f4ba29e82d696f5ce612f872499b4a42bb0ab33fcbf52abf36057c25448b3e29f30955dbc7e0ba34f10d21cb9b5d36e9ad9bf
+DIST tomlkit-0.11.7.tar.gz 188555 BLAKE2B 1958ace56c37746585879f1b657af53f36d1b3e741a5e41438a9806897e252bfbf42040c65a05df6c1921413da3e68be6d5d6ef9ce0a0c5d457b170f1cce6528 SHA512 456de2047fe1da1905ebf6eed99bdbd7d565fab2ecb50b9c06655188271d52b3680882ce0db2beb69fa9e7d18548b8045a99c4897e12e1d92d9cf92a937864ab
diff --git a/dev-python/tomlkit/tomlkit-0.11.7.ebuild b/dev-python/tomlkit/tomlkit-0.11.7.ebuild
new file mode 100644
index 000000000000..f9911e9a934d
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}