summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-05-09 20:52:05 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-05-09 20:52:05 +0000
commitd82f6364e078862a3c0d2f47735bf6207ab9d287 (patch)
treeaeda9818d4d24bf2ea10d37fd342692c76a96a23 /dev-python/tomli/tomli-2.0.1.ebuild
parent2022-05-09 20:35:37 UTC (diff)
parentdev-python/pytest-xdist: Enable py3.11 (diff)
downloadgentoo-d82f6364e078862a3c0d2f47735bf6207ab9d287.tar.gz
gentoo-d82f6364e078862a3c0d2f47735bf6207ab9d287.tar.bz2
gentoo-d82f6364e078862a3c0d2f47735bf6207ab9d287.zip
Merge updates from master
Diffstat (limited to 'dev-python/tomli/tomli-2.0.1.ebuild')
-rw-r--r--dev-python/tomli/tomli-2.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/tomli/tomli-2.0.1.ebuild b/dev-python/tomli/tomli-2.0.1.ebuild
index a3ce67d66ee5..ca6baab56cc2 100644
--- a/dev-python/tomli/tomli-2.0.1.ebuild
+++ b/dev-python/tomli/tomli-2.0.1.ebuild
@@ -5,19 +5,21 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A lil' TOML parser"
HOMEPAGE="
https://pypi.org/project/tomli/
- https://github.com/hukkin/tomli/"
+ https://github.com/hukkin/tomli/
+"
SRC_URI="
https://github.com/hukkin/tomli/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
- -> ${P}-py3-none-any.whl.zip"
+ -> ${P}-py3-none-any.whl.zip
+"
S=${WORKDIR}
LICENSE="MIT"
@@ -25,7 +27,8 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
BDEPEND="
- app-arch/unzip"
+ app-arch/unzip
+"
distutils_enable_tests unittest