summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 14:34:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 15:26:00 +0100
commit31221025482b1dc465550acf170b9d28b2542906 (patch)
treeece522cfd4a0ad06f0028cf3637b33dcf78296c2 /dev-python/sybil
parentdev-python/sybil: Enable py3.8 (diff)
downloadgentoo-31221025482b1dc465550acf170b9d28b2542906.tar.gz
gentoo-31221025482b1dc465550acf170b9d28b2542906.tar.bz2
gentoo-31221025482b1dc465550acf170b9d28b2542906.zip
dev-python/sybil: Enable tests, set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/sybil-1.2.0-r1.ebuild (renamed from dev-python/sybil/sybil-1.2.0.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/sybil/sybil-1.2.0.ebuild b/dev-python/sybil/sybil-1.2.0-r1.ebuild
index 07699278de28..3918a42c35cd 100644
--- a/dev-python/sybil/sybil-1.2.0.ebuild
+++ b/dev-python/sybil/sybil-1.2.0-r1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -14,6 +15,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="${DEPEND}"
+# nose is used to test nosetests integration
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest