summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-25 23:40:17 +0100
committerSam James <sam@gentoo.org>2023-04-25 23:40:17 +0100
commit128d1cc021dd711e4962d955478af79dd49c0d98 (patch)
treecfddf192a6b5222b76f1cc8989aaa3ab971dd5eb /dev-python/sip/sip-6.7.9.ebuild
parentdev-ruby/json: drop obsolete sed (diff)
downloadgentoo-128d1cc021dd711e4962d955478af79dd49c0d98.tar.gz
gentoo-128d1cc021dd711e4962d955478af79dd49c0d98.tar.bz2
gentoo-128d1cc021dd711e4962d955478af79dd49c0d98.zip
dev-python/sip: add 6.7.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sip/sip-6.7.9.ebuild')
-rw-r--r--dev-python/sip/sip-6.7.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sip/sip-6.7.9.ebuild b/dev-python/sip/sip-6.7.9.ebuild
new file mode 100644
index 000000000000..29b9c88145e5
--- /dev/null
+++ b/dev-python/sip/sip-6.7.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="
+ https://www.riverbankcomputing.com/software/sip/
+ https://pypi.org/project/sip/
+"
+
+if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit pypi
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+
+distutils_enable_sphinx doc --no-autodoc