summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ruledispatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ruledispatch')
-rw-r--r--dev-python/ruledispatch/Manifest1
-rw-r--r--dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch49
-rw-r--r--dev-python/ruledispatch/metadata.xml5
-rw-r--r--dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild46
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/ruledispatch/Manifest b/dev-python/ruledispatch/Manifest
new file mode 100644
index 000000000000..61c2aeaf2846
--- /dev/null
+++ b/dev-python/ruledispatch/Manifest
@@ -0,0 +1 @@
+DIST RuleDispatch-0.5a0.dev-r2306.tar.gz 186405 SHA256 0ce33a6ddda379f8a14c12e43286c31b54a24ccb1cf990078a634722c80d01c6 SHA512 5ee5f22b6ba755e79c108925d321ade10c6a2e06c309e753650385d2dfbeb2830eaeccee6b71338ec38598c877625b95acf21b6059faf91e9f6119e533b133b1 WHIRLPOOL 840b2176f61505619cc9fb615577f839523d68fc644b9b0c48b738744c8f20b0e054c23f951541734f52d605eab8967b0488f23145067b15c78c1127db4bbd33
diff --git a/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
new file mode 100644
index 000000000000..47960b3c23f5
--- /dev/null
+++ b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
@@ -0,0 +1,49 @@
+Added by: Jesus Rivero (Neurogeek)
+On: 25 Jul 2009
+Per Upstream bug: https://bugs.launchpad.net/ubuntu/+source/ruledispatch/+bug/342916
+
+diff -uNr RuleDispatch.orig/src/dispatch/__init__.py RuleDispatch/src/dispatch/__init__.py
+--- RuleDispatch.orig/src/dispatch/__init__.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/__init__.py 2009-07-25 13:27:19.000000000 +0000
+@@ -95,7 +95,7 @@
+ return decorate_assignment(callback)
+
+
+-def as(*decorators):
++def as_(*decorators):
+ """Use Python 2.4 decorators w/Python 2.2+
+
+ Example:
+Files RuleDispatch.orig/src/dispatch/__init__.pyc and RuleDispatch/src/dispatch/__init__.pyc differ
+Files RuleDispatch.orig/src/dispatch/interfaces.pyc and RuleDispatch/src/dispatch/interfaces.pyc differ
+diff -uNr RuleDispatch.orig/src/dispatch/predicates.py RuleDispatch/src/dispatch/predicates.py
+--- RuleDispatch.orig/src/dispatch/predicates.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/predicates.py 2009-07-25 13:27:58.000000000 +0000
+@@ -236,7 +236,7 @@
+
+ return or_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if item:
+@@ -260,7 +260,7 @@
+
+ return and_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if not item:
+@@ -278,7 +278,7 @@
+ return get(argIds[2])
+ return ifelse, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ if seq[1]: return seq[0]
+ return seq[2]
+
diff --git a/dev-python/ruledispatch/metadata.xml b/dev-python/ruledispatch/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/ruledispatch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
new file mode 100644
index 000000000000..ee6a2828e8e2
--- /dev/null
+++ b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils versionator flag-o-matic
+
+MY_PN="RuleDispatch"
+MY_P="${MY_PN}-$(get_version_component_range 1-2)a0.dev-$(get_version_component_range 3-)"
+MY_P="${MY_P/pre/r}"
+
+DESCRIPTION="Rule-based Dispatching and Generic Functions"
+HOMEPAGE="http://peak.telecommunity.com/"
+# http://svn.eby-sarna.com/RuleDispatch/
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="|| ( PSF-2.4 ZPL )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pyprotocols-1.0_pre2306[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=( "${FILESDIR}/${PN}_as_syntax_fix.patch" )
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ # parallel build makes a salad; einfo msg lets us see what's occuring
+ for test in dispatch/tests/test_*.py; do
+ "${PYTHON}" $test && einfo "Tests $test passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+ done
+ # doctest appears old and unmaintained, left for just in case
+ # "${PYTHON}" dispatch/tests/doctest.py
+ einfo "Tests passed under ${EPYTHON}"
+}