summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pywavelets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pywavelets')
-rw-r--r--dev-python/pywavelets/Manifest1
-rw-r--r--dev-python/pywavelets/metadata.xml16
-rw-r--r--dev-python/pywavelets/pywavelets-0.2.2-r1.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pywavelets/Manifest b/dev-python/pywavelets/Manifest
new file mode 100644
index 000000000000..c9792ae05e9d
--- /dev/null
+++ b/dev-python/pywavelets/Manifest
@@ -0,0 +1 @@
+DIST PyWavelets-0.2.2.zip 528210 SHA256 04b53436f5f2a9b895a1f56e86e16b94632a5d6bcfc076be1110e41cf3071278 SHA512 2cfd2b0e8f90750cc15ca60400101836f97661e52041abd4c032232eba6843b104c01ef2a50f4384afc5b11dd022add03101ef9b8c1b582ca64e84919f609a5b WHIRLPOOL 07dbec72901deb262a5f52954becee8ff4c9749fa311c206351db86c7612513dec329c6bcbad8e4ab6f1f1043ebfd08cfd8af762df95388789da13dfe6747e2a
diff --git a/dev-python/pywavelets/metadata.xml b/dev-python/pywavelets/metadata.xml
new file mode 100644
index 000000000000..610e1b9f018f
--- /dev/null
+++ b/dev-python/pywavelets/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<herd>python</herd>
+<longdescription lang="en">
+ PyWavelets is a Python wavelet transforms module that can perform:
+ * Discrete Wavelet Transform (1D and 2D)
+ * Inverse Discrete Wavelet Transform (1D and 2D)
+ * Stationary Wavelet Transform
+ * Wavelet Packets decomposition and reconstruction
+</longdescription>
+<upstream>
+ <remote-id type="pypi">PyWavelets</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pywavelets/pywavelets-0.2.2-r1.ebuild b/dev-python/pywavelets/pywavelets-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..d02576960f74
--- /dev/null
+++ b/dev-python/pywavelets/pywavelets-0.2.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="${PN/pyw/PyW}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for discrete, stationary, and packet wavelet transforms"
+HOMEPAGE="http://www.pybytes.com/pywavelets"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx )"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(CHANGES.txt THANKS.txt)
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" \
+ ${EPYTHON} tests/test_perfect_reconstruction.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*
+ fi
+}