summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-11-02 15:33:27 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-11-02 16:40:09 -0700
commitcd5a98df0cd6bae141a203f83f4fdb010f321799 (patch)
tree2373369995c18d3ce24d09b403ba38a5b3c8ec8c /dev-python/pytest-system-statistics
parentdev-python/boto: update EAPI 7 -> 8 (diff)
downloadgentoo-cd5a98df0cd6bae141a203f83f4fdb010f321799.tar.gz
gentoo-cd5a98df0cd6bae141a203f83f4fdb010f321799.tar.bz2
gentoo-cd5a98df0cd6bae141a203f83f4fdb010f321799.zip
dev-python/pytest-system-statistics: revbump, add py311, tarball
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest1
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
index 550382e4b516..1cd15b29538a 100644
--- a/dev-python/pytest-system-statistics/Manifest
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -1 +1,2 @@
+DIST pytest-system-statistics-1.0.2.gh.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..28c76f28eac4
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -k 'not proc_sys_stats'
+}