summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:17:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:40:14 +0300
commit15a313b22dc3ce8168b079eb27884307765b00d0 (patch)
tree9a64ea04008ed25c9b8b8e30ca4226b5fb364fca /dev-python/pygit2
parentsci-geosciences/readosm: drop 1.0.0e-r1, EAPI-6-- (diff)
downloadgentoo-15a313b22dc3ce8168b079eb27884307765b00d0.tar.gz
gentoo-15a313b22dc3ce8168b079eb27884307765b00d0.tar.bz2
gentoo-15a313b22dc3ce8168b079eb27884307765b00d0.zip
dev-python/pygit2: add 1.10.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.10.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 17b3f1b8f083..e20ad3e01f18 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1 +1,2 @@
DIST pygit2-1.10.0.gh.tar.gz 752095 BLAKE2B ff7759c504f49ed124e0e0504742bad02c4f07d7ebf78de8a8f37dba5344e30ca14bbad30cce8e9035f25525499cee0309bf0660f24ffa4594a5dcb527c105e5 SHA512 e3dd6b90eee43e633e790c066f63782a8f8077fece5d94e6d39ff8f869efdad8360fe52473a5ad0e61adb29a646ea091db6486655199c777df1b1af0e9894aae
+DIST pygit2-1.10.1.gh.tar.gz 752254 BLAKE2B b0f09eb65be19e9bb0e21afab4613478e1ad516f2cdd10c01328b73233e4e7f3a33d2c90c5ccb35a55050b18e6bf1e1dadb330457a78d0fed9d75da5a4082588 SHA512 d545b5919b6c1ef5411a20acc7463a7ff934852bef209c7254b33365ccb6e127f136537745088be387a07a70e99d2a12466570a515fcb9410216a34a565e7ea9
diff --git a/dev-python/pygit2/pygit2-1.10.1.ebuild b/dev-python/pygit2/pygit2-1.10.1.ebuild
new file mode 100644
index 000000000000..47951e5eef7a
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+SRC_URI="
+ https://github.com/libgit2/pygit2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.5*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}