summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-20 07:11:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-20 07:38:54 +0200
commit4b5b07848ed584332b951fe5a031ae0b6f6f1aaf (patch)
treeb8166073a22e9b2f66bbf19173cd3c89bc89453b /dev-python/pudb
parentdev-python/pudb: Remove old (diff)
downloadgentoo-4b5b07848ed584332b951fe5a031ae0b6f6f1aaf.tar.gz
gentoo-4b5b07848ed584332b951fe5a031ae0b6f6f1aaf.tar.bz2
gentoo-4b5b07848ed584332b951fe5a031ae0b6f6f1aaf.zip
dev-python/pudb: Bump to 2022.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/Manifest1
-rw-r--r--dev-python/pudb/pudb-2022.1.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pudb/Manifest b/dev-python/pudb/Manifest
index 23f0936dba6e..3698c1428533 100644
--- a/dev-python/pudb/Manifest
+++ b/dev-python/pudb/Manifest
@@ -1 +1,2 @@
DIST pudb-2022.1.1.tar.gz 218514 BLAKE2B 860e7a176d48a3a5424f86ec6dfabea70173b7e73ff3bc512e17c00ac3d7ff7e4f0a3b021e5ce1f38546643d035f4c567003b9808982e0fc4e49428cb08ae7b6 SHA512 0d098b2dac3442913ecf0827ed272dd57d6d03d44d6c67c6ddb8ef61bfc06f153e17aad60e5a0c17a490a675aba610b768289acf13ce9bc2603791b3c4012e4b
+DIST pudb-2022.1.2.tar.gz 219735 BLAKE2B fc2007b2be3a362d1198230815fd1642557c455ee0501e75784402ab88252e34806af1dbec20bc18f743b04b7133bde8466f48583d306002b341f3dececa62ab SHA512 73b9259a2ade953389d13b4e7df7179c54244700ffb1475e2fc5e3bb4a73259afa7b2b09a316aacbe47476fb6da3cf5b952cb082de51d6a953cd96a1eaf9cc4f
diff --git a/dev-python/pudb/pudb-2022.1.2.ebuild b/dev-python/pudb/pudb-2022.1.2.ebuild
new file mode 100644
index 000000000000..f321e07c4f40
--- /dev/null
+++ b/dev-python/pudb/pudb-2022.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwid_readline[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest