summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-11 18:05:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-11 18:42:08 +0100
commit4674af0ee02863ccf0f32a407fb0a6ed41541f74 (patch)
tree34686a1b1d95f2d00c67965da66dd43e402a14ac /dev-python/numexpr
parentdev-python/pylint: Bump to 3.0.3 (diff)
downloadgentoo-4674af0ee02863ccf0f32a407fb0a6ed41541f74.tar.gz
gentoo-4674af0ee02863ccf0f32a407fb0a6ed41541f74.tar.bz2
gentoo-4674af0ee02863ccf0f32a407fb0a6ed41541f74.zip
dev-python/numexpr: Bump to 2.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.8.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 1a4a8abb1c00..690c4568c9c0 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1 +1,2 @@
DIST numexpr-2.8.7.gh.tar.gz 118268 BLAKE2B eb4dec3a3fdf23617d499f4902022450de9b44fb99feff70b35443fb1797d3d0de31ae44841056651969a6ec4c47a1f1e060ac04b513b857fb47ccb82e04d677 SHA512 979b9df2bbb32b8f79aec0bb5b94e86c3d13c546aea7c9d81da76ab94fe93db0927dff16e497f4521f0c10df0243553ba6ee3f3b692493faac9a14f658044113
+DIST numexpr-2.8.8.gh.tar.gz 118241 BLAKE2B 409477cf69b64405359e86b11127fe31ccf6f940499fc5591498865fdef750a3321ff08ab5332caf0f11479927523d80699488f2985793a5f73f22b7467852bc SHA512 f89a2f04797ad4dffc3a591685e1a0e577912610d6b5359d2344a1a0a78873d951e95fa7c47833ab1008315467b861eb464442f85c06d1fe73f9743bcf358332
diff --git a/dev-python/numexpr/numexpr-2.8.8.ebuild b/dev-python/numexpr/numexpr-2.8.8.ebuild
new file mode 100644
index 000000000000..3c4417b5980c
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.8.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="
+ https://github.com/pydata/numexpr/
+ https://pypi.org/project/numexpr/
+"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+DEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}/install/$(python_get_sitedir)" >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test().wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}