summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 14:03:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 20:08:02 +0200
commit0d9980d5b08d124006030138eb090ca720adf092 (patch)
treec511372f1e897cfe697ef3b2543375af9783ed63 /dev-python/numexpr
parentdev-python/contourpy: Bump to 1.2.1 (diff)
downloadgentoo-0d9980d5b08d124006030138eb090ca720adf092.tar.gz
gentoo-0d9980d5b08d124006030138eb090ca720adf092.tar.bz2
gentoo-0d9980d5b08d124006030138eb090ca720adf092.zip
dev-python/numexpr: Bump to 2.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.10.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index b7c9611fcf4f..e2be3861ed5b 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1 +1,2 @@
+DIST numexpr-2.10.0.gh.tar.gz 119045 BLAKE2B b049ca51ef2fbdac4965d750d88c33b8c912280ac0e8b8039dea69e08f4bb4fde3003400fa64872b9145d7dfac98970d3ffbd05318d40399d4d9436480b50cfd SHA512 dfbad48a3e71dc1c6a618e7b62e9f8efe30b547935934e614df98c3134cbe00dee4f4515c6090d2f1a563f57b200ad806b861751ba1043aff43b07a0450baa11
DIST numexpr-2.9.0.gh.tar.gz 118463 BLAKE2B 04904a6faaff713b9775dc3601fcfc963b9bea5bc24e1d2ca21f0123d7dca8d088abef9b8da09195e9bf9fb6a4ff3b2bee0f75dbc5b40e174803cb726d8b1f31 SHA512 9d7319a872228faea845fbc8c2b85b5f9e941eb2e1308711835bdba37fce65543a23ad483b92e28c33b3eb341f2f7d75b760a0827ae63782fac573a65efdedb0
diff --git a/dev-python/numexpr/numexpr-2.10.0.ebuild b/dev-python/numexpr/numexpr-2.10.0.ebuild
new file mode 100644
index 000000000000..f18d721a9310
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="
+ https://github.com/pydata/numexpr/
+ https://pypi.org/project/numexpr/
+"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+DEPEND="
+ >=dev-python/numpy-1.19.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ # broken with > 8 CPU threads?
+ # https://github.com/pydata/numexpr/issues/479
+ sed -e 's:test_numexpr_max_threads_empty_string:_&:' \
+ -e 's:test_omp_num_threads_empty_string:_&:' \
+ -i numexpr/tests/test_numexpr.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pushd "${BUILD_DIR}/install/$(python_get_sitedir)" >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test(verbosity=2).wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}