summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:30:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:43:44 +0100
commitd57349a25e973b653773434b452bafc6fa10160f (patch)
treef97d1b2f6f6f85ba999f28ccf02c52af79c69ac6 /dev-python/minidb
parentdev-python/mecab-python: Switch to PEP 517 build (diff)
downloadgentoo-d57349a25e973b653773434b452bafc6fa10160f.tar.gz
gentoo-d57349a25e973b653773434b452bafc6fa10160f.tar.bz2
gentoo-d57349a25e973b653773434b452bafc6fa10160f.zip
dev-python/minidb: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/minidb')
-rw-r--r--dev-python/minidb/minidb-2.0.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/minidb/minidb-2.0.5-r1.ebuild b/dev-python/minidb/minidb-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..3806d2037aa7
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest