summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-25 18:50:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-25 18:53:01 +0100
commitf93c41dd5f0bcde14a9ae3342906ed5578c4e157 (patch)
tree8093a7c69da0d82f39742324a2d382d4582e9156 /dev-python/memory_profiler
parentdev-python/texttable: Remove old (diff)
downloadgentoo-f93c41dd5f0bcde14a9ae3342906ed5578c4e157.tar.gz
gentoo-f93c41dd5f0bcde14a9ae3342906ed5578c4e157.tar.bz2
gentoo-f93c41dd5f0bcde14a9ae3342906ed5578c4e157.zip
dev-python/memory_profiler: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.60.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index 398776b4ae98..693a1a0e2468 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,2 +1 @@
-DIST memory_profiler-0.60.gh.tar.gz 142585 BLAKE2B aa7fd9e547eecadc184d4da5830c582a9a9ab9565f3dc9c763caaa7e75698ed6b499d2555e4a93b39d2f80f85fad025b84043e0812cb25dd1511f4ebf8da5a85 SHA512 407e44a410cdb4c7c8cc5ff40198c28012f8b0c6bba88d2d1612681eb621a1b802ef137be62fc64ca9e3c362ca3814433bc12169d7c3827bf97293c5bbb8bfbc
DIST memory_profiler-0.61.gh.tar.gz 144680 BLAKE2B 418ae6e7433dd58b00c8706209a7172c31ccf57d74255aa670b271bc9d76b339bd582b48886bed7b53062abd8eb421678c911b3495de4d541b949f340aad7091 SHA512 02c70a049107ad4df635e20e22eaaa91fd4e4fd29690b0a7c314e08ed6e076bbb81f85dd97924ed35f7f0133cfd3c7e55b35400449489733beb172debe592c4e
diff --git a/dev-python/memory_profiler/memory_profiler-0.60.ebuild b/dev-python/memory_profiler/memory_profiler-0.60.ebuild
deleted file mode 100644
index 65cfca08bfe4..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.60.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.org/project/memory-profiler/ https://github.com/pythonprofilers/memory_profiler"
-SRC_URI="
- https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-IUSE="examples"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-# dev-lang/mercury: collision on 'mprof'
-# https://bugs.gentoo.org/571176
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- !dev-lang/mercury"
-
-distutils_enable_tests pytest
-
-python_test() {
- "${EPYTHON}" -m memory_profiler test/test_as.py || die
- "${EPYTHON}" -m memory_profiler test/test_func.py || die
- "${EPYTHON}" -m memory_profiler test/test_gen.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
- "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
- "${EPYTHON}" -m memory_profiler test/test_nested.py || die
- "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
- "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
-
- "${EPYTHON}" test/test_exception.py || die
- "${EPYTHON}" test/test_exit_code.py || die
- "${EPYTHON}" test/test_global.py || die
- "${EPYTHON}" test/test_import.py || die
- "${EPYTHON}" test/test_memory_usage.py || die
- "${EPYTHON}" test/test_mprof.py || die
- "${EPYTHON}" test/test_precision_import.py || die
- "${EPYTHON}" test/test_stream_unicode.py || die
- "${EPYTHON}" test/test_tracemalloc.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}