summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-17 06:45:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-17 06:45:48 +0100
commitf76692668e8f66fe48c310ce97e3c870c7de4a5e (patch)
tree8cffaf9c71b0978ae88940e4774fc51169dca48a /dev-python/memory_profiler
parentdev-python/dask: Bump to 2022.11.0 (diff)
downloadgentoo-f76692668e8f66fe48c310ce97e3c870c7de4a5e.tar.gz
gentoo-f76692668e8f66fe48c310ce97e3c870c7de4a5e.tar.bz2
gentoo-f76692668e8f66fe48c310ce97e3c870c7de4a5e.zip
dev-python/memory_profiler: Bump to 0.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.61.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index aaf7b94d12d1..398776b4ae98 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1 +1,2 @@
DIST memory_profiler-0.60.gh.tar.gz 142585 BLAKE2B aa7fd9e547eecadc184d4da5830c582a9a9ab9565f3dc9c763caaa7e75698ed6b499d2555e4a93b39d2f80f85fad025b84043e0812cb25dd1511f4ebf8da5a85 SHA512 407e44a410cdb4c7c8cc5ff40198c28012f8b0c6bba88d2d1612681eb621a1b802ef137be62fc64ca9e3c362ca3814433bc12169d7c3827bf97293c5bbb8bfbc
+DIST memory_profiler-0.61.gh.tar.gz 144680 BLAKE2B 418ae6e7433dd58b00c8706209a7172c31ccf57d74255aa670b271bc9d76b339bd582b48886bed7b53062abd8eb421678c911b3495de4d541b949f340aad7091 SHA512 02c70a049107ad4df635e20e22eaaa91fd4e4fd29690b0a7c314e08ed6e076bbb81f85dd97924ed35f7f0133cfd3c7e55b35400449489733beb172debe592c4e
diff --git a/dev-python/memory_profiler/memory_profiler-0.61.ebuild b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
new file mode 100644
index 000000000000..a5f150e6ca3a
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="
+ https://github.com/pythonprofilers/memory_profiler/
+ https://pypi.org/project/memory-profiler/
+"
+SRC_URI="
+ https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" -m memory_profiler test/test_as.py || die
+ "${EPYTHON}" -m memory_profiler test/test_func.py || die
+ "${EPYTHON}" -m memory_profiler test/test_gen.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
+ "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
+ "${EPYTHON}" -m memory_profiler test/test_nested.py || die
+ "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
+ "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
+
+ "${EPYTHON}" test/test_exception.py || die
+ "${EPYTHON}" test/test_exit_code.py || die
+ "${EPYTHON}" test/test_global.py || die
+ "${EPYTHON}" test/test_import.py || die
+ "${EPYTHON}" test/test_memory_usage.py || die
+ "${EPYTHON}" test/test_mprof.py || die
+ "${EPYTHON}" test/test_precision_import.py || die
+ "${EPYTHON}" test/test_stream_unicode.py || die
+ "${EPYTHON}" test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}