summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-03 12:13:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-03 12:13:14 +0300
commitbb8dc6b5760de8b3590a2e61907de77a2544cc9c (patch)
treeabed09ba3572160526d7181b33d89a7559004eb6 /dev-python/matterhook
parentdev-python/automat: Add a blocker on m2r (diff)
downloadgentoo-bb8dc6b5760de8b3590a2e61907de77a2544cc9c.tar.gz
gentoo-bb8dc6b5760de8b3590a2e61907de77a2544cc9c.tar.bz2
gentoo-bb8dc6b5760de8b3590a2e61907de77a2544cc9c.zip
dev-python/matterhook: EAPI=6->8, PEP517, py3.10, py3.11
Closes: https://bugs.gentoo.org/845750 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/matterhook')
-rw-r--r--dev-python/matterhook/matterhook-0.2-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/matterhook/matterhook-0.2-r2.ebuild b/dev-python/matterhook/matterhook-0.2-r2.ebuild
new file mode 100644
index 000000000000..3e4e7b6b0165
--- /dev/null
+++ b/dev-python/matterhook/matterhook-0.2-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"