summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-05 17:47:07 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-05 18:19:41 +0200
commitfdab7fc15aa348d070a5b901c0cfb0d76975ec0d (patch)
tree7788fc644cd110ac1be23f94ba3715d21db2971c /dev-python/lit
parentsys-boot/grub: typo (diff)
downloadgentoo-fdab7fc15aa348d070a5b901c0cfb0d76975ec0d.tar.gz
gentoo-fdab7fc15aa348d070a5b901c0cfb0d76975ec0d.tar.bz2
gentoo-fdab7fc15aa348d070a5b901c0cfb0d76975ec0d.zip
dev-python/lit: Add 3.9.0 release
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-3.9.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
new file mode 100644
index 000000000000..2f155b807708
--- /dev/null
+++ b/dev-python/lit/Manifest
@@ -0,0 +1 @@
+DIST llvm-3.9.0.src.tar.xz 18235716 SHA256 66c73179da42cee1386371641241f79ded250e117a79f571bbd69e56daa48948 SHA512 f18ae32531218ab156c3e56c11826be0fd05f0799c82eaf2e6a043b38e1277560b4d921987513b88b11d97ea2619feaf277eec72181dd2ae4f4108c2836bf7b2 WHIRLPOOL a36c1bcee6e7995067a9a7a51e3fdb0f10d51d0239250eefab92ed2e46b024a203fa10a17a25a5aca69046bcb413628e288427f1a6690d0862e07cd95694c8a8
diff --git a/dev-python/lit/lit-3.9.0.ebuild b/dev-python/lit/lit-3.9.0.ebuild
new file mode 100644
index 000000000000..6e832f5649ef
--- /dev/null
+++ b/dev-python/lit/lit-3.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+MY_P=llvm-${PV}
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+EGIT_REPO_URI="http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}.src/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+python_test() {
+ ./lit.py -sv tests || die
+}