summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-28 17:13:05 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-28 17:13:05 +0100
commitbdd35327270912bb167b345619093e3236375ec4 (patch)
tree79c890338f800b01876aab3368ee83e7e027b6d8 /dev-python/jira
parentdev-python/iso_639: Remove Py2 (diff)
downloadgentoo-bdd35327270912bb167b345619093e3236375ec4.tar.gz
gentoo-bdd35327270912bb167b345619093e3236375ec4.tar.bz2
gentoo-bdd35327270912bb167b345619093e3236375ec4.zip
dev-python/jira: Remove Py2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/jira')
-rw-r--r--dev-python/jira/jira-1.0.14-r2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/jira/jira-1.0.14-r2.ebuild b/dev-python/jira/jira-1.0.14-r2.ebuild
index 69e2892abc75..2c463d37e409 100644
--- a/dev-python/jira/jira-1.0.14-r2.ebuild
+++ b/dev-python/jira/jira-1.0.14-r2.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1
DESCRIPTION="Python library for interacting with the JIRA REST API"
@@ -13,8 +14,6 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="magic jirashell kerberos oauth"
-REQUIRED_USE="kerberos? ( !python_targets_python2_7 )
- jirashell? ( || ( $(python_gen_useflags -3) ) )"
DEPEND="
>=dev-python/pbr-3.0[${PYTHON_USEDEP}]
@@ -28,14 +27,15 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
magic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
jirashell? (
- $(python_gen_cond_dep '
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- ' -3)
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
)
- kerberos? ( $(python_gen_cond_dep 'dev-python/requests-kerberos[${PYTHON_USEDEP}]' -3) )
+ kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
oauth? (
- || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
dev-python/requests-oauthlib[${PYTHON_USEDEP}]
)
"