summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-05 03:46:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-05 03:53:36 +0200
commit20789e054f6bfcebc95902d8e2b02bf4ac7ae920 (patch)
tree2f60735700190aa9c697cd28fc48bc782117ac9e /dev-python/icalendar
parentdev-python/django-debug-toolbar: Enable py3.13 (diff)
downloadgentoo-20789e054f6bfcebc95902d8e2b02bf4ac7ae920.tar.gz
gentoo-20789e054f6bfcebc95902d8e2b02bf4ac7ae920.tar.bz2
gentoo-20789e054f6bfcebc95902d8e2b02bf4ac7ae920.zip
dev-python/icalendar: Bump to 6.0.0_alpha0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-6.0.0_alpha0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 3773d05a0138..29db86e2b26f 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,2 +1,3 @@
DIST icalendar-5.0.12.tar.gz 115981 BLAKE2B b6a778f78977b2e967f639ca1a6209002c003c0729a993217da2fa7d3e407d5fa696740daae7b3c1084588140675a2fb1346b39042fe869195d917b3a2436f49 SHA512 0b608054b955223c1b876c8395b94a501f6b5afb92285561750749882cde2d55cbb48487f7fcd64188d2d6cd193f3bdb5634871352eb5b7a445c483075a62453
DIST icalendar-5.0.13.tar.gz 119371 BLAKE2B ab0673af636b76682f1b0409df4333511c9cb19623dbdc639d84f46dcb9c14580ebfc1ea0465aa22b729852d5eaf76b12aa76041d189bcb3099f205caf43fac4 SHA512 df688298acc0bf3cf25aa08b16e149abab696e44540f11695a654065b90316189460481bde17d68e7c6760c1c4bfbbc74e9d7c7e3e640b5a1978d2c6faafbb78
+DIST icalendar-6.0.0a0.tar.gz 133899 BLAKE2B 33cc480e4c5422223837094f341b4057b374c0ec54ff56a27f9ade09a9dfe4f9c8c0ba295a811a9e2c457229183d5b4e335eff1fdd2f70d323664c4ba7203967 SHA512 79d7e4a634bbb68fbac1eccfb208f11bcf1ecfc061fd764e7370c0a33f8ae660e82d5d729404e87e6b1f8c5b3b35f1dbd1c2d22eb27ae5305efdd20177791fec
diff --git a/dev-python/icalendar/icalendar-6.0.0_alpha0.ebuild b/dev-python/icalendar/icalendar-6.0.0_alpha0.ebuild
new file mode 100644
index 000000000000..6ea93a735836
--- /dev/null
+++ b/dev-python/icalendar/icalendar-6.0.0_alpha0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tzdata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-copybutton \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}