summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-06 19:05:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-06 19:47:58 +0200
commit99c9a6eb2e8589814713e07475f35fd92e9bfc55 (patch)
treeab07fac740a7c9652d0765034e7a10baf8a104d7 /dev-python/hatchling
parentmedia-gfx/freecad: 0.19.4, 9999: Python 3.10 support added. (diff)
downloadgentoo-99c9a6eb2e8589814713e07475f35fd92e9bfc55.tar.gz
gentoo-99c9a6eb2e8589814713e07475f35fd92e9bfc55.tar.bz2
gentoo-99c9a6eb2e8589814713e07475f35fd92e9bfc55.zip
dev-python/hatchling: New NIH build system, v0.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest1
-rw-r--r--dev-python/hatchling/hatchling-0.22.0.ebuild69
-rw-r--r--dev-python/hatchling/metadata.xml11
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
new file mode 100644
index 000000000000..cbdd38ddb3fb
--- /dev/null
+++ b/dev-python/hatchling/Manifest
@@ -0,0 +1 @@
+DIST hatch-hatchling-v0.22.0.tar.gz 201590 BLAKE2B c75e48a19e10f04d9bb1d09beea0ec6598bded5dc9e595f363a076731b7708bae55169ee780931b548478c16db093053c65e30a5510f7b0136c1d339caf29d39 SHA512 cc532b66752d0494b62fb4ed88c8b7870d5618c991b301f46b644aa90b656cfe842efd2fa96797a6b96015deb3468ff8ff69058bd146133360de340d367a5489
diff --git a/dev-python/hatchling/hatchling-0.22.0.ebuild b/dev-python/hatchling/hatchling-0.22.0.ebuild
new file mode 100644
index 000000000000..2129e316e6e4
--- /dev/null
+++ b/dev-python/hatchling/hatchling-0.22.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/ofek/hatch/
+"
+SRC_URI="
+ https://github.com/ofek/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/editables-0.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # TODO: remove this when gpep517 is the norm
+ local -x PYTHONPATH=src
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x EPYTEST_DESELECT=(
+ # these run pip to install stuff
+ tests/backend/dep/test_core.py::test_dependency_found
+ tests/backend/dep/test_core.py::test_extra_met
+ tests/backend/dep/test_core.py::test_extra_no_dependencies
+ tests/backend/dep/test_core.py::test_extra_unmet
+ tests/backend/dep/test_core.py::test_unknown_extra
+ tests/backend/dep/test_core.py::test_version_unmet
+ )
+
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+ epytest -x tests/backend
+}
diff --git a/dev-python/hatchling/metadata.xml b/dev-python/hatchling/metadata.xml
new file mode 100644
index 000000000000..d4956b531605
--- /dev/null
+++ b/dev-python/hatchling/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ofek/hatch</remote-id>
+ <remote-id type="pypi">hatchling</remote-id>
+ </upstream>
+</pkgmetadata>