summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-01 20:08:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-01 20:43:17 +0200
commit07c89b58e2103d0ab87ff403e46b9d37dd0a560f (patch)
treec7eda388d51943c86b3f7c31494e6ee6480bf9e2 /dev-python/gssapi
parentnet-mail/notmuch: Remove DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-07c89b58e2103d0ab87ff403e46b9d37dd0a560f.tar.gz
gentoo-07c89b58e2103d0ab87ff403e46b9d37dd0a560f.tar.bz2
gentoo-07c89b58e2103d0ab87ff403e46b9d37dd0a560f.zip
dev-python/gssapi: fix test calls
Use better way to handle pytest C errors Fixes: 38695c204978839a830c4800e9ab669dcbc391f0 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/gssapi')
-rw-r--r--dev-python/gssapi/gssapi-1.7.2.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/gssapi/gssapi-1.7.2.ebuild b/dev-python/gssapi/gssapi-1.7.2.ebuild
index 3879ab4da406..491966350410 100644
--- a/dev-python/gssapi/gssapi-1.7.2.ebuild
+++ b/dev-python/gssapi/gssapi-1.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,6 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- cp -r -l -n gssapi "${BUILD_DIR}/lib" || die
- cd "${BUILD_DIR}/lib" || die
- epytest
+ cd "${T}" || die
+ epytest --pyargs gssapi
}